The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: Zeep-Eeep on February 19, 2004, 03:33:19 am



Title: Sound
Post by: Zeep-Eeep on February 19, 2004, 03:33:19 am
Currently when I run uqm and I'm already using the sound card (for music, other games, etc) I have to pass "--sound=none" on the command line.
If I don't and the sound card is in use, the program crashes.

I am wondering if anyone else has this problem? Also is there a planned
work around for this in the code?


Title: Re: Sound
Post by: Michael Martin on February 19, 2004, 04:20:02 am
This is in part an SDL issue and in part a function of how your system is set up.  UQM asks for access to the sound card; if it can't get it, it dies (and says that if you want to not have sound, to say so explicitly).  Depending on your OS and the options you compiled SDL with, you may be effectively guaranteed access.  I know that it will use esd if it can't get direct access to /dev/dsp on my system, but that's not because of anything UQM does, it is (again) SDL doing its job.

Printing a "couldn't open sound, playing silently" message would net us a trillion spurious "I can't make sound work on UQM" reports; automatically mixing with the OS's sound output is the kind of feature request you direct to the SDL developers, not us.

Questions about when to abort vs. when to play at reduced capabilities haven't really been seriously debated yet -- that's been shelved for a later date.