The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: T.W.A.I.N on December 05, 2002, 10:03:14 am

Title: Sun Device unreachable (bug in win32)
Post by: T.W.A.I.N on December 05, 2002, 10:03:14 am
Hey guys, loving the port so far. 10 years ago, SC2 to me represented the pinnacle of gaming. 10 years later, the same is still true.

Been playing it for a bit, but I ran into a bug that I couldn't find mentioned elsewhere. Upon returning to Betelguese and getting the mission from Talana and then going to go to the Mycon homeworld to tell them of Organon, something perplexing happened in the conversation.

As some other people have noticed the usual end conversation selection has been misrepresented as "bye sun device" triggering the incorrect mycon response of "GOODBYE SUN DEVICE". More curious is that unlike the other battle thrall homeworlds, selecting goodbye actually allows you to leave without a fight... That however is not the problem.

The moment I selected "There is a world at the star Organon..." choice the Mycon said "You are an obstruction to Juffo-Wup. You must be removed."  (listed as mycon060.ogg).

The major problem with this is that it did not trigger the correct response for them to leave their homeworld for me to get the Sun Device! Without that I can't assemble the utwig bomb to finish out the game (hard to do anyway, since right now the Sa-Matra is invunerable :)).

I went off for a few months, but so far no movement has occured -- and I'm betting won't. Went back to Talana, but she acts as if I still haven't told the Mycon about Organon. Attempting to recontact the Mycon and say the same line again have been unsuccesful.

I took a screenshot that I'll try and post later. Anybody else run into this?


Title: Re: Sun Device Work-Around
Post by: Anonymous on December 05, 2002, 10:32:56 am
This is my first time playing Star Control II and I have really enjoyed it. I also ran into this problem.

I solved it by delivering the message to the Mycon homeworld at Epsilon Scorpii. This triggered the desired response. I then recovered the sun device from Beta Brahe and recieved my reward from the Syreen.

Good luck.

Title: Re: Sun Device unreachable (bug in win32)
Post by: T.W.A.I.N on December 05, 2002, 11:18:41 am
Holy crap am I an idiot. I totally forgot you have to do it at Episilon Scorpii and not Beta Brahe. It's been way too long since I last played this  :-/.

Eh... My bad. It works fine now. False alarm.

If a mod would delete this thread so I could retain some bit of dignity, I'd appreciate it...  :-[


Title: Re: Sun Device unreachable (bug in win32)
Post by: Dutch on December 05, 2002, 04:58:29 pm
*Dutch points and laughs*

Haha! He forgot, haha!

*quickly scribbles down the solution*