The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: blitzoid on November 07, 2002, 07:46:58 pm

Title: Compiling info
Post by: blitzoid on November 07, 2002, 07:46:58 pm
Just thought I'd give you some info on compiling on different systems.

I grabbed the CVS from the night of Nov. 6th, attempted to run (Seemed to be the way to do it.), got this error:

./ Running aclocal
aclocal: 70: macro `AM_PATH_SDL' not found in library

My system:
Athlon XP 2000+/K7S5A ECS motherboard/256 of PC133/GeForce 2 MX (Running latest nVidia drivers)/Soundblaster LIVE! (Latest emu101 driver)

Slackware 8.1
SDL 1.2/SDL_image/SDL_mixer installed, OpenGL installed and working, Ogg Vorbis codec installed.

Most of this info probably has nothing to do with any of this, and the error was probably just that CVS, but hey, when troubleshooting, the more info the better. I checked line 70 of, but since I'm not much of a shell scripter, I couldn't see anything wrong. Seems to be a problem with SDL, but I can't see what.

Anyway... yeah.

Title: Re: Compiling info
Post by: meep-eep on November 08, 2002, 10:16:00 pm
The problem is that aclocal for some reason doesn't look at /usr/local/share/aclocal per default.
The solution would be:
1) run aclocal manually as 'aclocal -I /usr/loca/share/aclocal
2) run 'autoconf' (or delete configure and rerun
Note that adding the -I option in isn't a solution as for some configurations, it then finds multiple copies of some files and will fail on that.

Title: Re: Compiling info
Post by: umgod on November 16, 2002, 02:11:46 am
I was getting the same error with autogen when trying to compile in Linux. FYI, I am running Mandrake 9.0. I also had  SDL 1.2/SDL_image/SDL_mixer installed. It turns out that I did not have the SDL development packages installed. In Mandrake these are a series of development RPMS. I'm not sure what the package names would be for slackware. Here are the additional packages I had to install.

  • libSDL1.2-devel
  • libSDL_image1.2-devel
  • libSDL_mixer1.2-devel
  • libsmpeg0.4-devel (libsmpeg0.4 is also installed)
  • libvorbis0-devel (libvorbis0 is also installed)
  • libMesaGLU1-devel (libMesaGLU1 and libMesaglut3 were already installed...I'm not using a full install of Mesa, because I am using the Nvidia drivers for OpenGL. This package was needed in order to get the required glu.h file.)

The only other thing I had to do was make the following symbolic link (as root) due to a complaint about not being in the right place. I guess this depends on where resides on your system. SC2 wants it to be in /usr/X11R6/lib/. There may be a more elegant way of doing this with the configure script without using the symbolic link, but I was in a hurry and didn't bother trying to figure it out.

  • ln -s /usr/lib/ /usr/X11R6/lib/

Then all I did was run the following in a terminal:

  • ./
  • ./configure
  • make
  • make install (be sure to run this last one as root)

(Actually, I lied on the last one. I didn't run make install. I ran 'checkinstall -R' instead. That way it istalls the binaries using an RPM package which is very easy to uninstall.)

The only catch to this setup is that you have to run the 'sc2' command from the same directory where you ran make. Otherwise, it can not find the content files. It looks like this could also be overcome by passing the '--contentdir' option to sc2.

Anyway, this worked for me. Hopefully this helps you out, so you can get to brushing up on your melee skillz.

By the way. I would like to thank all the developers (if they happen to read this message) who have been working on this project. Some friends and I used to play an incredible amount of melee. It's been a long time since any of us have played, but hopefully that will change soon! Keep up the good work!:)

Here are a couple warnings/observations:

  • Super Melee seems to be working well. Few bugs. Melee is playable.:D
  • The actuall game locks up when visiting the starbase and answering the first question. So I'm not really able to play it.:(
  • A great job for a pre-alpha version!

Title: Re: Compiling info
Post by: Michael Martin on November 17, 2002, 04:56:46 am

Here are a couple warnings/observations:

  • The actuall game locks up when visiting the starbase and answering the first question. So I'm not really able to play it.:(

You appear to be using a rather old version of the source tree.  You may want to update.  We haven't required smpeg support for quite some time now, and the conversation bug that was crashing Linux was nailed a couple of weeks ago.  You should update your cvs trees and see if that's still going on.