The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: rodabon on September 13, 2004, 05:36:18 am

Title: After hitting f12 on accident game won't start
Post by: rodabon on September 13, 2004, 05:36:18 am
First of all a big thanks to the UQM team.  Thanks for bringing such a great game back to us.

I had played a ways into the game and decided I would change the keyboard setup.  I was editing my key configuration file and had did so two or three times trying to get my keys just how I liked. The last time after testing my latest change I went to exit the game and hit f12 instead of f10.  Every since then I haven't been able to get the game to start (much to my dismay).  The dos window pops up for a split second then back to desktop.

I'm running it on an XP OS.

I've uninstalled and reinstalled twice, the second time after downloading again to make sure my download was clean and I get the same result.

I really wanted to check your bug database but damn guys that is one complicated bug system and I haven't a lot of savy for this stuff.

I wanted to try your cvs patch thingy but again that was way over my head.  How in the world do you expect me to replace uqm.exe with that file and still start the game?  My computer doesn't recognize that file type and wouldn't I lose to cool Ur-Quan spaceship icon?  Any helpful steps I could take to fix this much appreciated.

Title: Re: After hitting f12 on accident game won't start
Post by: meep-eep on September 13, 2004, 09:20:39 am
F12 is an immediate exit. It should not prevent you from starting the game. However, there is a little bug that sometimes shows up: when you press F12, sometimes the game doesn't completely exit. I'm a Linux user myself so I don't know what this looks like on Windows, but you should just be able to terminate the process from the task manager. If you don't know how to do that, rebooting would work just as well. But I suspect you already tried that.

Are you sure your key config is actually correct? If you made a mistake there, the game may not start. Try putting back the original file (you can get a copy here (*checkout*/sc2/sc2/content/starcon.key) if necessary (rename to keys.cfg)).

Title: Re: After hitting f12 on accident game won't start
Post by: Profound_Darkness on September 14, 2004, 01:13:28 am
also, for further debuging, try runing uqm from a dos box (command prompt).  by running it from a command prompt UQM uses the prompt as it's console for information about what it is doing.  the command prompt won't close after UQM is done doing it's thing so you can read through what it printed.

If you don't know how to navigate dos then put one of the 2 lines below into the begining of your target line for a copy of your shortcut to UQM.
If win2k/winxp: CMD /K
if win95/98/me: COMMAND /K

NOTE the space following K is required and this needs to be in the target line.

Title: Re: After hitting f12 on accident game won't start
Post by: rodabon on September 15, 2004, 12:02:30 pm
Ok thanks guys.

I pried open the rusty trap I call a brain and was able to dredge up some of my old dos knowledge and did get the a dos window open (thanks profound_darkness) and was able to recall how to navigate directories and run uqm.exe.

It showed 4 errors on lines 20, 22, 24, and 26 of the key config file. These were where I had put in extra lines for wsad movement keys and had worked the first couple of times I had changed the file and I didn't see anything wrong with the lines themselves so following Meep-eeps suggestion I just pasted the original key config into it and saved.  Then I ran uqm.exe and just as I figured this hadn't completely solved my problem.

It got down past detecting the sound and right after checking for joysticks and detecting zero it comes up with the error 'Kernal failed to load!' which I assume is the game trying to start up.

Any other ideas?

Title: Re: After hitting f12 on accident game won't start
Post by: meep-eep on September 15, 2004, 09:51:54 pm
This cannot have anything to do with your pressing of F12. Perhaps with the reinstalling.
If it gives the kernel error, that usually means it can't find the content .zip file. Per default it looks in a number of locations relative to the current dir, so if you start the game from a non-standard location or have the content .zip file put elsewhere, you'll need to supply the -n switch on the command line (see "uqm -h").