The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: acheng on September 01, 2005, 06:35:40 am

Title: Too fast!
Post by: acheng on September 01, 2005, 06:35:40 am
Hi, I just downloaded v0.4.0 and began playing SC2 for the first time...  The problem I have is the lander and space fight sequences are way too fast!  I managed to survive Mercury due to fast reactions to the flames and earthquakes, but after returning to the outpost for the third time and being forced into battle by the spider thingy, I die before I can do anything!

I mean, the battle is finished in about one second...   (and I am dead > <)

Is there anything I can do to help me play this game?


Title: Re: Too fast!
Post by: Novus on September 01, 2005, 08:06:23 am
Is there anything I can do to help me play this game?
If you have problems with battles, you could use the Cyborg mode to let the computer fight for you. However, the computer pilot is not very good, so your best option is just to practise.

The Ilwrath Avenger attacking you near the start of the game, BTW, is seriously damaged and not much of a threat. Taking it out with your Earthling Cruiser should be easy. At the beginning of the game, your flagship is almost completely useless in battle (it's far too slow), so try to avoid using it.

If a situation is too dangerous, ask yourself if you really need to be in it.

Title: Re: Too fast!
Post by: Megagun on September 01, 2005, 11:53:22 am
He is already using Cyborg mode, in the fast setting...

Since Cyborg sucks ass, turn it off... This will slow down the game, and actually let YOU pilot the damn ship....

For planets, well, you'll just need experiene with that... Note that some aliens in the game can sell you upgrades for the landing vehicle which might help you a lot.. :)

Title: Re: Too fast!
Post by: Culture20 on September 02, 2005, 01:59:55 am
And Mercury is a dangerous planet to gather radioactives from too.  Doesn't Io have a few?

Title: Re: Too fast!
Post by: n on September 14, 2005, 05:25:50 pm
It's too fast for me too; when I'm exploring a planet's survface for example, I have a hard time controlling the lander. I'm thinking about installing spyware on my system to slow everything down! Kidding. But seriously, I'm not using cyborg mode, and it's not even battles that are a problem for me.

Title: Re: Too fast!
Post by: meep-eep on September 14, 2005, 05:36:54 pm
Some planets are just too dangerous for anyone to avoid all dangers. It's better to leave them alone until your landers are better equipped to deal with them.

Title: Re: Too fast!
Post by: n on September 15, 2005, 08:48:28 pm
I thought I'd post my solution to the problem, for those who actually believe I had a problem.  :P Unfortunately, I think this may only work if you are running uqm in VMWare. You can change the amount of memory allocated to the virtual machine. I lowered mine to 128 Mb, and the fight scenes were actually doable by a hunam in real time.

For those who still don't think I (or the original poster) had an actual problem, imagine this: you are flying through the solar system, trying to land on a planet. You TAP the arrow key to change direction, and end up doing a 360 degree turn. DOes that sound like a problem to you? If not, then I'm not sure what is.

Title: Re: Too fast!
Post by: meep-eep on September 15, 2005, 09:41:40 pm
Ok, that does sound like a real bug. One that would be worth reporting in our bug database.
Does that only happen in VMWare? How fast is your PC?
The fact that lowering the amount of memory helped sounds really strange, so it may be an important clue.