The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: Orzy-man! on June 21, 2006, 05:59:55 pm



Title: Game won't start
Post by: Orzy-man! on June 21, 2006, 05:59:55 pm
 I have been trying to work with UQM because it stopped working a couple of months ago. I reinstalled it about 9 times from 9 different mirors, no missing files. So I looked in the source and found this

(http://i11.photobucket.com/albums/a186/stinkometroid20x6/Sourceproblem.png)

Well I updated the soundcard, didn't work. Don't know how to use the --sound=none option. And the onlything that seems to be a big problem is openAL. Anybody got any leads?


Title: Re: Game won't start
Post by: Novus on June 22, 2006, 12:30:42 am
Did you read the UQM Technical FAQ (http://uqm.stack.nl/wiki/The_Ur-Quan_Masters_Technical_FAQ#How_do_I_change_my_settings.3F)?

Incidentally, --sound=mixsdl ought to fix your sound problems; use that instead.

meep-eep, about changing that default sound driver... :(


Title: Re: Game won't start
Post by: Orzy-man! on June 22, 2006, 01:59:40 am
I would but how do I use it? Where do I enable that option?


Title: Re: Game won't start
Post by: Gen. Bridge on June 22, 2006, 10:53:22 am
Ah, I've got that before. Just do as it says. For some reason, UQM won't run if it can't find a good sound card. I don't know what you could do to make the game notice the new sound card, though.

~ Lt. Bridge

P.S.
Quote
I would but how do I use it? Where do I enable that option?
Use it from the command line. For example, if the game is called uqm, just type uqm --sound=none, or uqm -sound=mixsdl.


Title: Re: Game won't start
Post by: Novus on June 22, 2006, 01:56:13 pm
I would but how do I use it? Where do I enable that option?
You did follow the link I gave you to the detailed instructions in the UQM technical FAQ (http://uqm.stack.nl/wiki/The_Ur-Quan_Masters_Technical_FAQ#How_do_I_change_my_settings.3F), didn't you?


Title: Re: Game won't start
Post by: Orzy-man! on June 22, 2006, 09:29:28 pm
OK I downloaded the UQM loader and set the sound to none and it still wont run.

Here is another picture of the NEW error.


(http://i11.photobucket.com/albums/a186/stinkometroid20x6/Moreproblems.png)


Title: Re: Game won't start
Post by: Novus on June 22, 2006, 11:06:12 pm
OK I downloaded the UQM loader and set the sound to none and it still wont run.
Hmm. Looks like Mark hasn't updated the launcher for version 0.5 yet. Try the other solution in the FAQ; the one involving editing shortcuts.


Title: Re: Game won't start
Post by: Orzy-man! on June 23, 2006, 01:50:27 am
I tried that first. I right clicked the shortcut, and "preferences" didn't come up. So I clicked the closest thing to it "properties" to see if that would help. It didn't do anything. Preferences never comes up when I right click anything. Could that be because I have windows XP (home edidtion)?


Title: Re: Game won't start
Post by: Novus on June 23, 2006, 10:33:51 am
Nothing wrong with your system. The FAQ entry was just badly translated from Dutch or something; the instructions were OK but the names were wrong. I fixed it to match the English version of Windows (Me and XP at least; I don't have anything else available right now).


Title: Re: Game won't start
Post by: Orzy-man! on June 23, 2006, 10:57:26 pm
OK I tried the other way and it STILL didn't work! Here is the message I got!

(http://i11.photobucket.com/albums/a186/stinkometroid20x6/Error.png)


Title: Re: Game won't start
Post by: Novus on June 23, 2006, 11:34:32 pm
I think you have a space missing after the closing double quote.


Title: Re: Game won't start
Post by: Orzy-man! on June 24, 2006, 01:54:13 am
There has yo be a space?


Title: Re: Game won't start
Post by: Orzy-man! on June 24, 2006, 02:09:50 am
I followed your advice and finnally got it to work. Thank you! :D


Title: Re: Game won't start
Post by: Novus on June 24, 2006, 12:11:22 pm
I followed your advice and finnally got it to work. Thank you! :D
Great! Is that with or without sound? As I mentioned, using "--sound=mixsdl" instead of "--sound=none" should give you sound.


Title: Re: Game won't start
Post by: Orzy-man! on June 26, 2006, 05:27:59 am
It works with sound and all. Just like it used to. Thank you Novus!