The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: rsl1506 on February 05, 2008, 02:04:13 pm

Title: Controller Issue
Post by: rsl1506 on February 05, 2008, 02:04:13 pm
Ok, here's what happened.  I hadn't played this game in a while (I've previously had ver. 0.5.0) and decided that I wanted to give this game another go.  I downloaded ver. 0.6.2 and I'm having trouble with my logitech dual action usb.  Even after mapping the buttons in the options menu, the buttons would not respond properly.  For example, when I would hit the weapon button to scan a planet, it would open the menu, but then not scan.  I tried the enter key on the keyboard, and it worked to get the scan started, but not the button on the controller.  I even tried a keyboard to joystick emulator (joy2key) figuring that would solve my problem, but it did the exact same thing?!  The button would not activate scan or open menus, but the enter key would!  I thought it was an issue with this new version, because I remember ver. 0.5.0 worked with my controller with no problem at all.  Started looking on my hard drive, and found that I had that version kicking around, so I started that one up.  It did the exact same thing!  Anyone encounter this problem before??  TIA for your time!

Title: Re: Controller Issue
Post by: lakota.james on February 05, 2008, 07:54:16 pm
I had some problems with a joypad not to long ago. what I had to do was delete a file called keys.cfg. This is where it is: "C:\Documents and Settings\Lakota\Application Data\uqm" where "Lakota" is your user name. then make sure you have the pad plugged in BEFORE you run the game. That fixed it for me.

Title: Re: Controller Issue
Post by: Michael Martin on February 06, 2008, 11:16:29 am
Note that 0.6.2 has some reported problems with non-digital gamepads.  If you find that your ships are spinning out of control, the issue has been fixed in the unofficial binaries.