The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: Nician on June 16, 2008, 07:06:25 am

Title: Ubuntu sound problems solved
Post by: Nician on June 16, 2008, 07:06:25 am
I was unable to get sound on Ubuntu 8.04.

I had installed the Ubuntu uqm packages and downloaded and unpacked the -voice and -3domusic .uqm files and unpacked them in the content tree.

Sound is working (Rythmbox, flash player, etc.) but I had two problems with uqm

First, with my default Ubuntu install, I got the following error that prevented the game from even starting unless sound was disabled (--sound=none)

ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave

Hacking on ALSA/Pulseaudio, (setting Pulse as the default in .asoundrc) could make the error go away and the game would start, but still no sound.  And upon exit, the game would hang.  So I assume that the sound thread is blocking someplace...

In searching further, I found this:

which mentions that SDL 1.2.12 has direct support for PulseAudio, but a default install doesn't include the pulse support, rather it selects only alsa in the form of package "libsdl1.2debian-alsa"

So I replaced it with "libsdl1.2debian-all" and then launch uqm with "export SDL_AUDIODRIVER=pulse"

Tada!!  Sound, and quiting the game exits immediately.