The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: zefciu on January 07, 2009, 02:41:18 pm



Title: Problem with gamepad
Post by: zefciu on January 07, 2009, 02:41:18 pm
I am playing ur-quan masters 0.6.2 under Ubuntu Intrepid and I just bought Logitech Precision Gamepad.  When launching uqm I see it's name in the logs, but besides the game doesn't react.  I can't control the menu with my pad and when I configure the controls and the game asks me for a key or direction, nothing happens no matter if I press the directional button or one of the fire buttons.  The pad works well with other games.  How can I help?  I tried to edit the keys.cfg - still nothing, mayby I should adjust the thresholds somehow, but I don't know how.


Title: Re: Problem with gamepad
Post by: Novus on January 07, 2009, 04:05:53 pm
This is a known problem: UQM removes game controller support from its configuration if you don't have a controller (or, to be precise, all references to a controller that is not available are removed). This means that if you run UQM without a gamepad, it will ignore one that is plugged in later. The easiest work-around is to delete keys.cfg.


Title: Re: Problem with gamepad
Post by: zefciu on January 07, 2009, 04:59:33 pm
Thanks.  I read about this problem but I misunderstood it.  I thought it's about the current run of uqm, not any run.  This one is fixed.  But still a problem.

This pad is not analog.  At least technically, because the presses of the directional button are mapped to axes.  When testing with jstest I get 128-128 for non-pressed 128-1 for up 128-255 for down 255-128 for right etc.  I have read http://hkn.eecs.berkeley.edu/~mcmartin/vcontrol/doc/user.html and I see, that uqm rather expects signed values 0-0 for center etc.  I have tried to play with threshold value but I have only two choices:  when I set it to a number > 128 then I can move only down and right.  When i set it to a number < 128 it moves itself down and right and I can only stop it.  How can I recalibrate it?

EDIT:  I am terribly sorry.  I have just solved this problem with jscal.  I don't know why jscalibrator didn't work before, but now it''s ok.