The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: Zrie on June 19, 2012, 07:19:01 pm



Title: Successful compile - strange error when entering setup
Post by: Zrie on June 19, 2012, 07:19:01 pm
Hey, there!

This isn't super critical, as the config files are editable, but I was wondering what could have caused this - I had a successful compile of the latest SVN using MinGW.  Everything compiles & runs well, but going into the setup menu off of the main menu throws a fatal error - "Panic: Incorrect number of Choice Options."

I'm used to failed compiles, but I've never seen this one off a successful build.  Anyone have any ideas at all?

Also, I apologize in advance if I'm posting this here in error - I wasn't considering this to be a bug, merely something I missed (or messed up) while setting up the compile.

Thanks in advance!


Title: Re: Successful compile - strange error when entering setup
Post by: meep-eep on June 19, 2012, 09:23:31 pm
All technical issues can go to this forum, so this is the right place.

One way in which this error might occur is when the version of the content and the source differ. Make sure that you have the same version for everything.

A failed SVN merge could be another reason. You might want to examine content/base/ui/setupmenu.txt for weirdness.



Title: Re: Successful compile - strange error when entering setup
Post by: Zrie on June 19, 2012, 11:47:01 pm
And I'll be a .......  If that wasn't it.   My content wasn't consistent with the source.  Thanks again!