The Ur-Quan Masters Discussion Forum

The Ur-Quan Masters Re-Release => Technical Issues => Topic started by: Robert Penz on December 02, 2002, 01:04:23 am



Title: hang at first visit at earth
Post by: Robert Penz on December 02, 2002, 01:04:23 am
Hi!

I've just downloaded it and cool, melee has the same still the same feeling ;-)

but my problem now is that I always hangs at the first visit at earth, during the speech of the commander suddenly nothing happens, but th e music is still running and no error message on the console.

one time I was able to get to choose my anwser, but after I pressed DOWN, it hang again ...

using the current static linux version

./uqm -o -c=bilinear -r 1024x768 -p

ps: I get always exactly 50 fps bevor freeze ;-)


Title: Re: hang at first visit at earth
Post by: Bill on December 02, 2002, 01:39:38 am
I have the same issue with no error code.  ???


Title: Re: hang at first visit at earth
Post by: ozric on December 02, 2002, 01:43:57 am
Me Too.... Gentoo RC 1.4 SDL lib 1.2.6


Title: Re: hang at first visit at earth
Post by: petril on December 02, 2002, 11:01:42 am
I have exactly the same bug, I run UQM in Windows 98 Me..
So sad, I have been waiting this great game for so long! :'(

But, hopefully developers can make a fix that doesn't require downloading the same 140 megs package again  ;D


Title: Re: hang at first visit at earth
Post by: gravity on December 02, 2002, 12:04:16 pm
Same for me, running Debian unstable and uqm compiled myself from the 0.1 source release. Compiled and run with libsdl 1.24. I don't hear the voices, just the music, which is as I expect with the old version of sdl-mixer. Music still plays after the game hangs but the game doesn't respond to keyboard commands any more. No options are passed to uqm when it's run.


Title: Re: hang at first visit at earth
Post by: meep-eep on December 02, 2002, 06:44:39 pm
It's a known to happen for some people. As a workaround, you can press space to skip the speech.


Title: Re: hang at first visit at earth
Post by: Dave Morse on December 03, 2002, 12:12:30 am
Debian 3.0,
staticly linked.
Same problemo


Title: Re: hang at first visit at earth
Post by: dysan2k on December 03, 2002, 12:25:24 am
I'm not sure about the statically linked version, but as for the general can't-hear-speech fix, you can't use the stable 1.2.4 SDL_mixer, you have to download/compile the lastest CVS for SDL_mixer and make sure it compiles with Ogg Vorbis support.  It will enable the use of .ogg files, which is what the speech is in (Huzaah!  No mp3!).  As for the hangups, someone on another post mentioned they were due to deadlocks.. gonna go sniff around a bit more to see if I can nail where those are occurring.

BTW, EXCELLENT work all!  You are to be highly commended!


Title: Re: hang at first visit at earth
Post by: Alex on December 03, 2002, 05:59:31 am
i installed the static and dynamic and it still paused for me, but i fould a workaroud. if you go to get the radioactivs first then go to earth it works


Title: Re: hang at first visit at earth
Post by: umgod on December 03, 2002, 09:26:45 am
If you are compiling it yourself on linux, I recommend choosing OpenAL support for sound. This allowed me to hear the speaches when using SDL_mixer did not. OpenAL support can be selected by running 'build uqm config' before compiling.

I had one other catch before I could get it working. I have an Aureal Vortex 2 based sound card using the 1.1.2 vortex drivers from sourceforge . I needed to place a file named '.openalrc' in my home directory that contains the following line:

(define native-use-select #f)

Otherwise, I can't get sound from any OpenAL app. By the way, I'm running Mandrake 9.0. I also have the problem where the game hangs during the conversation screens. On linux this usually happens during the first visit to earth. On Windows 98 I was able to get much farther into the game without a hang, but eventually it froze during one of the conversation screens. By the way, I believe this is a known buy (at the top of the TODO list). For whatever reason the problem seems to occur more frequently in linux.

Oh well, it's still great for an alpha version. It's nice to be playing melee again.