The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
October 25, 2020, 11:48:17 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

  Show Posts
Pages: [1]
1  The Ur-Quan Masters Re-Release / Technical Issues / Re: Successful compile - strange error when entering setup on: June 19, 2012, 11:47:01 pm
And I'll be a .......  If that wasn't it.   My content wasn't consistent with the source.  Thanks again!
2  The Ur-Quan Masters Re-Release / Technical Issues / Successful compile - strange error when entering setup on: June 19, 2012, 07:19:01 pm
Hey, there!

This isn't super critical, as the config files are editable, but I was wondering what could have caused this - I had a successful compile of the latest SVN using MinGW.  Everything compiles & runs well, but going into the setup menu off of the main menu throws a fatal error - "Panic: Incorrect number of Choice Options."

I'm used to failed compiles, but I've never seen this one off a successful build.  Anyone have any ideas at all?

Also, I apologize in advance if I'm posting this here in error - I wasn't considering this to be a bug, merely something I missed (or messed up) while setting up the compile.

Thanks in advance!
3  The Ur-Quan Masters Re-Release / Technical Issues / Re: 2 errors on MSVC 05 compile on: May 19, 2008, 08:17:52 pm
my apologies - I should have included line numbers.  I think the first numbers are the error/warning count.  The line that MVSC pointed to was 232.
4  The Ur-Quan Masters Re-Release / Technical Issues / 2 errors on MSVC 05 compile on: May 19, 2008, 04:24:16 pm
Hey, there.  Back once again.  Has anyone else run into problems compiling the last 10 builds or so with MVSC 05?  I'm getting 2 errors stopping the compilation from module "resinit.c" :

483 error C2275: 'CharHashTable_HashTable' : illegal use of this type as an expression
484 error C2065: 'map' : undeclared unidentifier

If anyone has seen this, let me know.

If it's just another issue with MSVC, then I'm just going to go the mingw route from now on.  Too many problems.
5  The Ur-Quan Masters Re-Release / Technical Issues / Re: Could not copy default key config... yadda, yadda. Problem & one solution on: January 05, 2008, 08:50:19 pm
Yep - just to be sure, I went and DLed / ran the installer (Windows, obviously) just to get the packs over again.  0.6.2 content zips.  Starcon2.key exists, uqm.key doesn't.  Those are, indeed,  the ones I've been using.  Please forgive me; I've been running v6.2 up until a little while back, when the compiled exe just refused to run because of this error.  I never remade the content pack until this past Thursday.

Runs like a champ now.
6  The Ur-Quan Masters Re-Release / Technical Issues / Re: Could not copy default key config... yadda, yadda. Problem & one solution on: January 03, 2008, 10:26:55 pm
I seem to post before I truly think things out.  Didn't realize that it's neccessary to zip up a new content archive from the svn.  Everything's working as well as can be expected.

Oy.
7  The Ur-Quan Masters Re-Release / Technical Issues / Could not copy default key config... yadda, yadda. Problem & one solution on: January 03, 2008, 10:18:47 pm
Noticed when trying to compile off the SVN recently that I was getting a lot of errors relating to "Could not copy default key config to user config dir: no such file or directory."  I went through all of the posts with no luck.  After going through a bit of the code (and looking in the content file), I noticed that UQM was trying to copy out uqm.key, but the file in the content archive was starcon.key.  a quick rename and...  another error.  well, at least that's one problem fixed.  Sorry if this was mentioned in another post - I haven't seen anything relevant since 0.6.0.
8  The Ur-Quan Masters Re-Release / Technical Issues / Re: VC++ 2k5 compile problems on: January 25, 2007, 03:29:34 am
Replying to my own post.  How odd is that?

I think I may have figured out what was up.  After fiddling around with vc++2k5, I changed a couple of things.

1st - I ran the "register PSDK directories with Visual Studio" item under the Platform SDK Start menu item.

2nd - msvc has its config environment set to "Debug - NoAccel."  It seems to work better with "Release - NoAccel," though I don't get the console window anymore.  I'm sure I can change this in the project settings, but there you go.  A friend of mine mentioned that the compile works differently with the debug config active & may use a different set of DLLs or not link the DLLs correctly.

In any case, it seems to work now.  If anyone has a better description, let me know.
9  The Ur-Quan Masters Re-Release / Technical Issues / Re: VC++ 2k5 compile problems on: January 24, 2007, 07:14:42 pm
Hm...  Would those be included in the steps in INSTALL.msvc?  If so, I'm pretty sure I got those, as well.  Copied all of the .DLLs into the sc2 dir before compiling, and added each .lib directory and .dll directory mentioned in install.msvc from the individual unzipped archives to "additional include directories" and "additional library directories" in VC++ 2k5 express.  Basically just plugged everything in as per the text.  When I re-make the .exe, I move the entire uqm dir and the DLLs I copied to the sc2 source dir to the new machine.  Is there something else I could be missing?

I'm used to MS' development environments not adding in all of the dependencies that are needed, and that was the only explanation that I could come up with as to why it would work on the development machine and not on a machine that doesn't have the Platform SDK / SDL / OGG / zlip / OpenAL / MSVC packages installed.

I'd compile it under linux if I thought it'd be easier, but that would end up taking forever...  At least for me.
10  The Ur-Quan Masters Re-Release / Technical Issues / VC++ 2k5 compile problems on: January 24, 2007, 06:12:41 pm
Hey, all.

I've recently been trying to re-compile UQM 0.6.2 from the source.  I've been trying to use VC++ 2k5 simply because I had it lying around & I've used it before (albeit a tiny bit).  The compile goes fine, 0 errors, 370 warnings, and produces an executable.  When moved into my uqm dir and run, it seems to run fine.  if my re-compiled exe moves to ANOTHER machine, though, execution errors out with "This application has failed to start because the application configuration is incorrect.  Reinstalling the application may fix this problem."    I've followed the INSTALL.msvc to the lettter, but keep getting this error.

Any ideas?
11  The Ur-Quan Masters Re-Release / General UQM Discussion / Re: campaign editor for UQM on: July 14, 2006, 02:09:50 am
Actually, a friend of mine coded a ship editor and crack for the ORIGINAL Starcon 2.  He was a pretty good programmer - if anyone hex edits the .com files on the original Star Control Collection CD, his name is still in there.  I'll mail & see if he's worked on anything like this, but I doubt it.
Pages: [1]


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!