The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
December 02, 2022, 12:52:16 am
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

  Show Posts
Pages: [1]
1  The Ur-Quan Masters Re-Release / Technical Issues / Re: A few problems after a MinGW compile. on: February 02, 2009, 06:05:06 am
Well, when running the config command, it does the checking and finding before calling
up the list of configuration options. In the first directory, it lists vorbis and zlib as 'found',
and selecting them in their option sections is possible.

In the second directory, vorbis and zlib are listed as 'not found' and in the options list,
you can not select them as they weren't found. It is rather odd, as the two directories
are 'next' to each other, so to speak. They are both in the 'uqm-0.6.2-source' directory.
The one that works is 'uqm-current' and the one that doesn't is just 'uqm'.

It's no real problem, as one of them DOES work, but this does indicate a mistake on my
part. Gotta find it eventually. Smiley

Greywolf
2  The Ur-Quan Masters Re-Release / Technical Issues / Re: A few problems after a MinGW compile. on: February 01, 2009, 02:07:03 am
Oh, BTW, the other problem. In the source directory I'm using, running the
"C_INCLUDE_PATH=/usr/include:/usr/local/include ./build.sh uqm config" command
finds all the libraries for compiling without any problem, but going to the second
source directory containing the 'snapshot' code and executing the same command
has the zlib and vorbis libraries missing. I had thought that after installing the
libraries into mingw would make them available in either source directory. Do I
need to do something else to have the compiler find them in the second source
directory?

Starkiller
3  The Ur-Quan Masters Re-Release / Technical Issues / Re: A few problems after a MinGW compile. on: February 01, 2009, 01:53:26 am
Problem solved. I don't know why it never occurred to me, to check the original. There WAS
an active argument. Your EXE was using the 'opengl' switch. I added that to my command
line, and now we have it working. Nice job, BTW. I played the original many moons ago,
right after it was released. I also had SC1 for computer and genesis. Never did get three
though. Smiley Thanks again. Will pester you some more, when I have more questions.

BTW, have you seen 'UFO:Alien Invasion'? If you are an X-Com fan, check it out. It's on
the Open Source website too, like UQM. Those were the days of awesome scifi.

Starkiller
4  The Ur-Quan Masters Re-Release / Technical Issues / Re: A few problems after a MinGW compile. on: February 01, 2009, 12:54:32 am


Here's the little warning I get. I run it from the 'Start' menu, like the original.
It's rather curious. I'm used to MS-DOS, having started with that when Windoze
was still in it's infancy. UNIX is similar, yet different enough to cause problems.
I'm wondering why zlib and vorbis are available from one directory, yet not an the
other. In MS-DOS, anything added with the PATH command was accessible from
any directory.

Starkiller
5  The Ur-Quan Masters Re-Release / Technical Issues / A few problems after a MinGW compile. on: January 31, 2009, 11:48:33 pm
Well, after much head banging (poor poor wall), I finally got a working EXE file. The problem
is that it doesn't run. It keeps telling me that I have extra arguments found on the command
line, and to use '-h' to find acceptable arguments. I'm not using any command line
arguments. I'm trying to run it 'clean'.

Assuming a possible bug, I DLed the latest source 'snapshot'. Installed it in a separate
directory and tried the compile. vorbis and zlib were missing, but in the original source
directory, they aren't. When I installed them, as per the instructions, shouldn't they be
available from any directory? Any help appreciated here. Kind of a bummer to finally
get an executable that won't execute. Smiley

Starkiller
Pages: [1]


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!