The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
April 16, 2024, 10:26:48 am
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

  Show Posts
Pages: [1]
1  The Ur-Quan Masters Re-Release / General UQM Discussion / Re: The MegaMod 0.8.0 has finally arrived! on: April 04, 2018, 06:53:22 pm
I've installed using the windows msi installer, however I can't find anyway to actually activate any of the options I installed (I installed them all).  What am I missing?
2  The Ur-Quan Masters Re-Release / Technical Issues / Re: flashing video on Debian Squeeze on: April 25, 2012, 02:22:20 am
I'm using the libsdl1.2debian-alsa drivers, but I'll swap them out and give it a try real quick...  Same issue.  The (somewhat) good news is that this is happening for other sdl programs which makes me think that it's an issue with the way SDL interfaces with the framebuffer, it is a very young device.
3  The Ur-Quan Masters Re-Release / Technical Issues / Re: flashing video on Debian Squeeze on: April 25, 2012, 12:56:19 am
Never even heard of it Tongue
4  The Ur-Quan Masters Re-Release / Technical Issues / Re: No OpenGL Can I use OpenGL ES? on: April 25, 2012, 12:53:37 am
yeah, I'd be fine with the normal res, but using sdl the screen display for a second then goes black, I'm hoping using open gles will fix that
5  The Ur-Quan Masters Re-Release / Technical Issues / Re: No OpenGL Can I use OpenGL ES? on: April 24, 2012, 03:21:29 am
I must confess that the more things go towards video stuff the less I understand, but I'm trying :-)  I see the part of the file that talks about openGL, to get it to look at openGLES do I change the part that says "name=openGL" and then just ./build.sh uqm?
6  The Ur-Quan Masters Re-Release / Technical Issues / No OpenGL Can I use OpenGL ES? on: April 23, 2012, 08:46:05 pm
As the topic says, I can't use openGL, the framebuffer has a weird error which I made another thread about, so I'm wondering if it would be possible to use OpenGL ES instead of openGL?  Is anyone aware of a port that already does this very thing or can tell me what file I would need to edit to update the code for openGL instructions?
7  The Ur-Quan Masters Re-Release / Technical Issues / Re: flashing video on Debian Squeeze on: April 23, 2012, 08:20:17 pm
More information, I can't use openGL as the device only support openGL ES.  Is there a port of UQM that uses openGL ES?
8  The Ur-Quan Masters Re-Release / Technical Issues / Re: flashing video on Debian Squeeze on: April 23, 2012, 04:05:31 pm
Here's a log file of when I try to run it from console without x server when it causes the screen to flash an image for a moment then go black

The Ur-Quan Masters v0.7.0 (compiled Apr 22 2012 22:16:24)
This software comes with ABSOLUTELY NO WARRANTY;
for details see the included 'COPYING' file.

Netplay protocol version 0.4. Netplay opponent must have UQM 0.6.9 or later.
Initializing base SDL functionality.
Using SDL version 1.2.14 (compiled with 1.2.14)
init kbd.
Using config dir '/root/.uqm/'
Using '/usr/local/games/share/uqm/content' as base content dir.
Warning: There's no 'addons' directory in the 'content' directory;
   '--addon' options are ignored.
Saved games are kept in /root/.uqm/save/.
Initializing Pure-SDL graphics.
SDL driver used: fbcon
SDL initialized.
Initializing Screen.
Set the resolution to: 640x480x32
  Video: R 00ff0000, G 0000ff00, B 000000ff, A 00000000
  Internal: R 00ff0000, G 0000ff00, B 000000ff, A ff000000
Screen scalers are using optimized C code
0 joysticks were found.
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Opening SDL audio device.
    using alsa at 44100 Hz 16 bit stereo, 3968 samples audio buffer
Initializing mixer.
Mixer initialized.
Initializing sound decoders.
Sound decoders initialized.
Loading resource index 'uqm.rmp'
Warning: There's no 'addons' directory in the 'content' directory;
   '--addon' options are ignored.
Warning: There's no 'addons' directory in the 'content' directory;
   '--addon' options are ignored.
   'base/uqm.ct' -- 104466 bytes
We've loaded the Kernel
Thread 'Unknown (probably renderer)' blocking on mutex 'Fade Lock'
   'base/ui/title.ani' -- 20 bytes
   'base/ships/arilou/skiff-icons.ani' -- 60 bytes
   'base/ships/arilou/skiff-meleeicons.ani' -- 66 bytes
   'base/ships/arilou/skiff.txt' -- 407 bytes
   'base/ships/chmmr/avatar-icons.ani' -- 60 bytes
   'base/ships/chmmr/avatar-meleeicons.ani' -- 70 bytes
   'base/ships/chmmr/avatar.txt' -- 353 bytes
   'base/ships/human/cruiser-icons.ani' -- 62 bytes
   'base/ships/human/cruiser-meleeicons.ani' -- 71 bytes
   'base/ships/human/cruiser.txt' -- 331 bytes
   'base/ships/orz/nemesis-icons.ani' -- 64 bytes
   'base/ships/orz/nemesis-meleeicons.ani' -- 72 bytes
   'base/ships/orz/nemesis.txt' -- 389 bytes
   'base/ships/pkunk/fury-icons.ani' -- 58 bytes
   'base/ships/pkunk/fury-meleeicons.ani' -- 66 bytes
   'base/ships/pkunk/fury.txt' -- 329 bytes
   'base/ships/shofixti/scout-icons.ani' -- 60 bytes
   'base/ships/shofixti/scout-meleeicons.ani' -- 66 bytes
   'base/ships/shofixti/scout.txt' -- 395 bytes
   'base/ships/spathi/eluder-icons.ani' -- 61 bytes
   'base/ships/spathi/eluder-meleeicons.ani' -- 70 bytes
   'base/ships/spathi/eluder.txt' -- 382 bytes
   'base/ships/supox/blade-icons.ani' -- 59 bytes
   'base/ships/supox/blade-meleeicons.ani' -- 67 bytes
   'base/ships/supox/blade.txt' -- 321 bytes
   'base/ships/thraddash/torch-icons.ani' -- 60 bytes
   'base/ships/thraddash/torch-meleeicons.ani' -- 68 bytes
   'base/ships/thraddash/torch.txt' -- 339 bytes
   'base/ships/utwig/jugger-icons.ani' -- 62 bytes
   'base/ships/utwig/jugger-meleeicons.ani' -- 70 bytes
   'base/ships/utwig/jugger.txt' -- 315 bytes
   'base/ships/vux/intruder-icons.ani' -- 66 bytes
   'base/ships/vux/intruder-meleeicons.ani' -- 72 bytes
   'base/ships/vux/intruder.txt' -- 249 bytes
   'base/ships/yehat/terminator-icons.ani' -- 70 bytes
   'base/ships/yehat/terminator-meleeicons.ani' -- 77 bytes
   'base/ships/yehat/terminator.txt' -- 425 bytes
   'base/ships/melnorme/trader-icons.ani' -- 61 bytes
   'base/ships/melnorme/trader-meleeicons.ani' -- 70 bytes
   'base/ships/melnorme/trader.txt' -- 369 bytes
   'base/ships/druuge/mauler-icons.ani' -- 61 bytes
   'base/ships/druuge/mauler-meleeicons.ani' -- 70 bytes
   'base/ships/druuge/mauler.txt' -- 333 bytes
   'base/ships/ilwrath/avenger-icons.ani' -- 62 bytes
   'base/ships/ilwrath/avenger-meleeicons.ani' -- 72 bytes
   'base/ships/ilwrath/avenger.txt' -- 365 bytes
   'base/ships/mycon/podship-icons.ani' -- 64 bytes
   'base/ships/mycon/podship-meleeicons.ani' -- 72 bytes
   'base/ships/mycon/podship.txt' -- 329 bytes
   'base/ships/slylandro/probe-icons.ani' -- 58 bytes
   'base/ships/slylandro/probe-meleeicons.ani' -- 68 bytes
   'base/ships/slylandro/probe.txt' -- 367 bytes
   'base/ships/umgah/drone-icons.ani' -- 60 bytes
   'base/ships/umgah/drone-meleeicons.ani' -- 66 bytes
   'base/ships/umgah/drone.txt' -- 367 bytes
   'base/ships/urquan/dreadnought-icons.ani' -- 71 bytes
   'base/ships/urquan/dreadnought-meleeicons.ani' -- 80 bytes
   'base/ships/urquan/dreadnought.txt' -- 425 bytes
   'base/ships/zoqfotpik/stinger-icons.ani' -- 64 bytes
   'base/ships/zoqfotpik/stinger-meleeicons.ani' -- 72 bytes
   'base/ships/zoqfotpik/stinger.txt' -- 367 bytes
   'base/ships/syreen/penetrator-icons.ani' -- 70 bytes
   'base/ships/syreen/penetrator-meleeicons.ani' -- 77 bytes
   'base/ships/syreen/penetrator.txt' -- 343 bytes
   'base/ships/kohrah/marauder-icons.ani' -- 64 bytes
   'base/ships/kohrah/marauder-meleeicons.ani' -- 74 bytes
   'base/ships/kohrah/marauder.txt' -- 429 bytes
   'base/ships/androsynth/guardian-icons.ani' -- 66 bytes
   'base/ships/androsynth/guardian-meleeicons.ani' -- 73 bytes
   'base/ships/androsynth/guardian.txt' -- 389 bytes
   'base/ships/chenjesu/broodhome-icons.ani' -- 66 bytes
   'base/ships/chenjesu/broodhome-meleeicons.ani' -- 76 bytes
   'base/ships/chenjesu/broodhome.txt' -- 369 bytes
   'base/ships/mmrnmhrm/xform-icons.ani' -- 58 bytes
   'base/ships/mmrnmhrm/xform-meleeicons.ani' -- 68 bytes
   'base/ships/mmrnmhrm/xform.txt' -- 395 bytes
   'base/fonts/starcon.fon' -- 1 bytes
   'base/fonts/tiny.fon' -- 1 bytes
   'base/ui/activity.ani' -- 259 bytes
   'base/ui/status.ani' -- 144 bytes
   'base/gamestrings.txt' -- 15449 bytes
   'base/fonts/micro.fon' -- 1 bytes
   'base/ui/menu.snd' -- 56 bytes
_GetSoundBankData(): loading base/ui/menusnd01.wav
_GetSoundBankData(): decoded bytes 1971
_GetSoundBankData(): loading base/ui/menusnd02.wav
_GetSoundBankData(): decoded bytes 1955
_GetSoundBankData(): loading base/ui/menusnd03.wav
_GetSoundBankData(): decoded bytes 1576
_GetSoundBankData(): loading base/ui/menusnd04.wav
_GetSoundBankData(): decoded bytes 2399
   'base/battle/stars.ani' -- 66 bytes
   'base/battle/boom-big.ani' -- 227 bytes
   'base/battle/boom-med.ani' -- 229 bytes
   'base/battle/boom-sml.ani' -- 230 bytes
   'base/battle/blast-big.ani' -- 208 bytes
   'base/battle/blast-med.ani' -- 208 bytes
   'base/battle/blast-sml.ani' -- 208 bytes
   'base/battle/asteroid-big.ani' -- 649 bytes
   'base/battle/asteroid-med.ani' -- 609 bytes
   'base/battle/asteroid-sml.ani' -- 609 bytes
   'base/ui/newgame.ani' -- 183 bytes
Trying to get undefined resource 'music.mainmenu'
9  The Ur-Quan Masters Re-Release / Technical Issues / Re: flashing video on Debian Squeeze on: April 23, 2012, 07:18:45 am
More information, when I start up my screen in 640x480 mode and try to run the program, right after it attempts to initialize the screen it says "segmentation error" I'm using "Pure SDL"
10  The Ur-Quan Masters Re-Release / Technical Issues / flashing video on Debian Squeeze on: April 22, 2012, 04:37:59 pm
I'm trying to get UQM to run on a computer called the Raspberry Pi.  I have all the required packages installed and have tried installing it from apt-get as well as building it from source.  It works fine from within x-server but the Raspberry Pi is an extremely lightweight computer and doesn't have the oomph to handle running it in X11.  But when I try to run it using just the framebuffer outside X, it will flash the main image then will go black, then it will flash the menu and go black.  Until I load up a new screen or it times out and starts the credits everything will be black.  Does anyone have an idea about what might be causing this issue?
Pages: [1]


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!