The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
July 20, 2024, 12:40:21 pm
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

  Show Posts
Pages: [1]
1  The Ur-Quan Masters Re-Release / Technical Issues / Re: Running uqm on _low_ level machines on: May 21, 2004, 08:29:27 pm
The difference between music 3do and pc is very slight. Removing sounds from within the game doesn't help much either. The best response seems to come from --sound=none, but I really wouldn't want to do that.
Oh well...
2  The Ur-Quan Masters Re-Release / Technical Issues / Re: Running uqm on _low_ level machines on: May 14, 2004, 03:06:20 pm
Yah, already tried --audioquality=low, compiled openal in and tried that.
Neither makes much difference.
Even disabling sounds doesn't cure, only helps.

I was just wondering that since there are options for just about every feature in the game, whether there are any that affect the planetside. It would appear that the only ones are the overall graphical resolution/bitdepth and sounds. --scanlines doesn't seem to do anything by the way.
Personally I would be willing to live with an option --planetview=off, but then again very few people will try playing on such antiquated machinery. This is none too important for me, I have other machines. But having some free time I thought I might give it a try and was quite positively surprised.
3  The Ur-Quan Masters Re-Release / Technical Issues / Re: Running uqm on _low_ level machines on: May 13, 2004, 07:26:06 pm
ADDENDUM:
Nope, it chokes fatally on --bpp=8 and doesn't understand 320x200 (which interestingly causes it to default to 640x480) Reading the log it still insists on using 22050Hz, 16 bit stereo for audio. On this machine I would settle for a lot less, but I can't control that.

In any case, I think I have proven that the minimum specs are correct, and with a slightly more powerful machine it would be fully playable.

As an added annoyance, the biggest gripe I have with the original DOS SC2 is the planetside. On the PC version you have a minimal postmark view around the lander, especially when compared with the 3DO version.
4  The Ur-Quan Masters Re-Release / Technical Issues / Re: Running uqm on _low_ level machines on: May 13, 2004, 07:08:12 pm
Hmm, I thought it was 320x240, but nevertheless I have fiddled with just about all of the options. Does the --bpp=8 work, it's not mentioned in the documentation?
There doesn't seem to be any difference between mixsdl and openal. I still wouldn't like to disable sounds.
I was just wondering if there is anything that would affect planetside specifically since everything else works surprisingly smoothly.
Unfortunately the machine has an old ATI MACH32 card so opengl is really not an option.
It's surprising that the problem is with the planet, since they are really not that graphicallly or otherwise impressive. I was expecting to have problems with melee, but it works fine.
5  The Ur-Quan Masters Re-Release / Technical Issues / Running uqm on _low_ level machines on: May 13, 2004, 03:45:06 pm
Having played and enjoyed uqm on a modern computer, I decided to try and run it on my trusty 200 MHz machine, just out of curiosity. According to the specs this is the minimum, and after poking around with the options I manage to make it playable.
EXCEPT for the lander. On all planets and especially on hostile planets with lots of quakes or lightning the controls become choppy and unresponsive. It seems to boil down to the sounds, turning them off makes the problem less, but not vanish. None of the options seem to affect the planetside. Navigation is smooth, speech works (with blue background), melee works good enough, so it's annoying being left with this one problem.
Is there anything I could try? Running the latest release snapshot 0.32
Pages: [1]


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!