The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
July 09, 2020, 07:26:54 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Missing some files
« previous next »
Pages: [1] Print
Author Topic: Missing some files  (Read 2089 times)
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Missing some files
« on: July 16, 2003, 08:55:16 am »

I just retrieved the source files from CVS, but I seem to be missing SDL.h and al.h.  They don't seem to be anywhere in the CVS structure.  Is there something obvious I'm missing, or can I retrieve these files elsewhere?
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Missing some files
« Reply #1 on: July 16, 2003, 12:18:19 pm »

Quote
I just retrieved the source files from CVS, but I seem to be missing SDL.h and al.h.  They don't seem to be anywhere in the CVS structure.  Is there something obvious I'm missing, or can I retrieve these files elsewhere?
You seem to be missing the SDL and OpenAL header files. You can get SDL here or from most Linux distributions. OpenAL should not be necessary; UQM compiles fine without it for me. However, it can be downloaded here. Again, if you are using Linux, check your distribution.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Mika
Core Team
*Many bubbles*
*****
Offline Offline

Gender: Male
Posts: 121



View Profile WWW
Re: Missing some files
« Reply #2 on: July 16, 2003, 06:29:58 pm »

Read INSTALL in sc2/ dir, it lists all required libs (+ download locations).
Logged
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Re: Missing some files
« Reply #3 on: July 16, 2003, 09:18:57 pm »

I'm attempting to compile this with MSVC++ 7.0, and I'm getting several linking errors having to do with the unresolved external symbols "_inflate", etc. in some of the zip functions.  Any thoughts?

:: Edited out stupid questions ::
« Last Edit: July 16, 2003, 11:15:14 pm by Glitch » Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Missing some files
« Reply #4 on: July 17, 2003, 09:58:22 am »

You'll need zlib. See INSTALL.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Re: Missing some files
« Reply #5 on: July 17, 2003, 10:49:13 am »

I have zlib, that's the problem.  Before I installed zlib, I got errors complaining about its absence.  Now that it's installed, I'm getting linking errors.  I just can't win.
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Missing some files
« Reply #6 on: July 17, 2003, 08:21:51 pm »

Hmm. If you're using the UrQuanMasters.dsp project file that is included with the source, it should link with zlib.lib.
I'm not a Windows user myself, but I know it worked for other people.
Maybe someone else has a useful hint.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Re: Missing some files
« Reply #7 on: July 17, 2003, 08:43:53 pm »

Out of frustration, I did a clean build and it linked fine this time.  I don't really know why; I didn't change anything from the last build.

Thanks for putting up with my stupid questions; this looks great!
« Last Edit: July 17, 2003, 08:57:47 pm by Glitch » Logged
Mika
Core Team
*Many bubbles*
*****
Offline Offline

Gender: Male
Posts: 121



View Profile WWW
Re: Missing some files
« Reply #8 on: July 17, 2003, 08:51:48 pm »

Linking error indicates it isn't finding your zlib.lib; either it's in wrong dir, you haven't added it to library search path from Tools/Options/Projects/VC++ Directories/Library Files, or it's wrong version. The one I use is from http://www.winimage.com/zLibDll/zlib114dll.zip and works fine for VC7.
« Last Edit: July 17, 2003, 08:52:53 pm by admin » Logged
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Re: Missing some files
« Reply #9 on: July 17, 2003, 08:58:22 pm »

Thank you for your help; I edited the post above.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!