The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
August 03, 2020, 05:20:05 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Okay, another stupid question
« previous next »
Pages: [1] Print
Author Topic: Okay, another stupid question  (Read 2086 times)
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Okay, another stupid question
« on: July 17, 2003, 09:43:04 pm »

Using the build of UQM that I compiled, it doesn't play any speech.  The debug information in the console window says that it can't find the .ogg files, but the .ogg files are in the proper place (content/comm).  The background music that occurs while talking to aliens works perfectly, so it obviously finds the .mod files fine.  I suspect that I could have built it wrong(again), but this is stumping me.  Any thoughts?
« Last Edit: July 17, 2003, 09:46:14 pm by Glitch » Logged
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Re: Okay, another stupid question
« Reply #1 on: July 18, 2003, 01:28:28 am »

For example, this is what appears in the console window during the conversation with the Kzer-Za drone:

Found timestamp file: comm/urquan/urquan.ts
       'comm/urquan/urquan.mod' -- 75885 bytes
_GetMusicData(): loading comm/urquan/urquan.mod
   decoder: MikMod, rate 44100 format 170202
SpliceTrack(): loading comm/urquan/urqua027.ogg
SpliceTrack(): number of timestamps doesn't match number of pages!
SpliceTrack(): no voice ogg available so setting speech volume to zero
at pos 0 to stream comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg
StreamDecoderTaskFunc(): buffer underrun when playing comm/urquan/urquan.mod, so
urce 5
, source 6derTaskFunc(): buffer underrun when playing comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg
at pos 0 to stream comm/urquan/urqua027.ogg

I think the buffer underruns happened because I was watching the console window instead of the game window, and the sound stopped until I switched back to the game window.

Now that I look at that again, I'm unsure of the meaning of "no voice ogg available."  Does that mean that the .ogg file isn't there, or is it saying there's no decoder for it?
« Last Edit: July 18, 2003, 01:36:00 am by Glitch » Logged
Mika
Core Team
*Many bubbles*
*****
Offline Offline

Gender: Male
Posts: 121



View Profile WWW
Re: Okay, another stupid question
« Reply #2 on: July 18, 2003, 01:51:54 am »

I can duplicate this problem by converting urquan.txt to CRLF so it's actually a bug (code assumes unix-style line endings for text files and doesn't work otherwise; your CVS program seems to do the conversion, I use Cygwin's CVS which doesn't do that and so works fine).

I added it to bugzilla, it will be fixed with the new resource system or possibly earlier.
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Okay, another stupid question
« Reply #3 on: July 18, 2003, 04:17:36 am »

Fixed now, though most of this code will go when the new resource system is done.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Re: Okay, another stupid question
« Reply #4 on: July 18, 2003, 06:47:24 am »

I decided the easiest way to fix the carriage returns would be to simply copy the "comm" directory from the .20 release over the one I retrieve from CVS.  This fixed the speech.  However, the lander communication messages had random line feeds in them, and several screens worth of garbage at the end.  I figured this was another line feed problem, so I copied the entire .20 "content" directory over the one from CVS.  Now, the executable crashes on startup right after the message about "starcon.key" with the error:

Unhandled exception at 0x00000000 in uqmdebug.exe: 0xC0000005: Access violation reading location 0x00000000.

The debugger points to line 319 in getres.c.  I don't understand this; surely the game content doesn't change from version to version?  Any ideas?
« Last Edit: July 18, 2003, 07:29:25 am by Glitch » Logged
Mika
Core Team
*Many bubbles*
*****
Offline Offline

Gender: Male
Posts: 121



View Profile WWW
Re: Okay, another stupid question
« Reply #5 on: July 18, 2003, 08:28:53 am »

Quote
I don't understand this; surely the game content doesn't change from version to version?  Any ideas?

Content _does_ change between versions, so you cannot get the game working with CVS sources and 0.20 content.
Logged
Glitch
Zebranky food
*
Offline Offline

Posts: 23


I love YaBB 1G - SP1!


View Profile
Re: Okay, another stupid question
« Reply #6 on: July 18, 2003, 09:40:01 am »

Yeah, I realize that now; I had taken "content" to mean "static content."  Lips Sealed
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!