The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
June 15, 2021, 08:24:37 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Slackware 10 error durring compilation
« previous next »
Pages: [1] Print
Author Topic: Slackware 10 error durring compilation  (Read 1739 times)
Allan
Guest


Email
Slackware 10 error durring compilation
« on: February 10, 2005, 10:41:59 am »

Greetings,

I'm having an issue compiling the game on my Slackware 10 system.  After untaring and zipping everything and copying the uqm-0.3-content.zip into content/packages, I run "./build.sh uqm" from the uqm-0.3 directory. I then accepted the default settings.
It will do it's thing for about 15 seconds, then I get this:

gcc -o obj/debug/./src/sc2code/libs/graphics/sdl/3do_blt.o -c  -I/usr/local/include/SDL -D_REENTRANT -I/usr/local/include/SDL -D_REENTRANT -g -O0 -W -Wall -DDEBUG_TRACK_SEM -DGFXMODULE_SDL -DHAVE_OPENGL  -DSOUNDMODULE_SDL  -DHAVE_ZIP=1  -I src -I src/sc2code -I src/sc2code/libs
gcc: no input files
make: *** [obj/debug/./src/sc2code/libs/graphics/sdl/3do_blt.o] Error 1

I checked the path, and there is indeed no such file "3do_blt.o".

I'm now a bit lost as to how to continue...

I'm running a relatively unmodified version of Slackware 10 with the 2.4.26 kernel on an Athlon XP 3000+.  I have all the libraries needed (such as SDL, zlip, etc.). Let me know if you need more details...

Thanks in advance for anyone who is able to help.

Allan
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Slackware 10 error durring compilation
« Reply #1 on: February 10, 2005, 11:44:32 am »

As far as I can tell, make is trying to produce obj/debug/./src/sc2code/libs/graphics/sdl/3do_blt.o by compiling no file at all. Thus, gcc complains that it hasn't been given any input files. You should have a file called src/sc2code/libs/graphics/sdl/3do_blt.c and this file should be used in this step. If the file is missing, make can't pass its name to gcc. You probably have a damaged install of the source code. Another possibility is that the build script or the makefile generated by the build script is broken.

I strongly recommend downloading the latest version of UQM from CVS anyway; v0.3 is horribly out of date and trying to compile it is a waste of time.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Slackware 10 error durring compilation
« Reply #2 on: February 10, 2005, 02:54:52 pm »

This used to happen when you interrupted the dependency building process.
Do "./build.sh uqm depend" and wait patiently and your "./build.sh uqm" should go ok. But I recommend you run the CVS version instead.
There are snapshots here if you prefer.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!