The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
July 07, 2022, 02:59:56 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Sound delays under ALSA
« previous next »
Pages: [1] Print
Author Topic: Sound delays under ALSA  (Read 1370 times)
Kai
Guest


Email
Sound delays under ALSA
« on: March 31, 2004, 02:09:44 pm »

I'm using 2.6.4 and ALSA sound, with an onboard ASUS A7N8X Deluxe sound card, and ALL sound in UQM is delayed by about two seconds.

I will fire a shot, see it hit, and two seconds later, hear the impact.

Any ideas why?
Logged
0xDEC0DE
*Many bubbles*
***
Offline Offline

Posts: 175



View Profile WWW
Re: Sound delays under ALSA
« Reply #1 on: March 31, 2004, 07:21:30 pm »

Because light travels faster than sound?  (sorry, I couldn't resist)  Smiley

Does the problem still occur if you switch to an OSS audio driver?  I'm running UQM on a 2.4.x kernel with an OSS driver and have no problems, so as I see it, the problem is in one of two possible places -- The kernel or the driver.

Also, are you using a software mixer like artsd or esound, or are you using the raw audio device?  Does switching to one or the other make a difference?
Logged

"I’m not a robot like you. I don’t like having disks crammed into me… unless they’re Oreos, and then only in the mouth."  --Fry
Michael Martin
Core Team
*Smell* controller
*****
Offline Offline

Posts: 387



View Profile
Re: Sound delays under ALSA
« Reply #2 on: April 09, 2004, 07:17:26 am »

Esound definitely does this (and it does it for EVERYTHING, not just UQM).  I find that it doesn't happen if UQM is the only sound-using program going when I start it up.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!