The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
October 05, 2022, 05:28:17 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Compile on Solaris.
« previous next »
Pages: [1] Print
Author Topic: Compile on Solaris.  (Read 1684 times)
Mycom Squasher
Guest


Email
Compile on Solaris.
« on: August 07, 2004, 04:24:27 am »

I'm trying to compile uqm 0.3 on solaris and I'm find that the build.sh script is broken and it's begining to look like it's going to be a pain to compile. I saw that the freebsd folk have their own makefiles and what not to make this compile. Any pointers on solaris?
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Compile on Solaris.
« Reply #1 on: August 07, 2004, 05:45:28 am »

The build.sh script works fine on FreeBSD.
We unfortunately do not have any developers or contributors on Solaris. I don't know of anyone who even tried to compile it there. I have access to one Solaris machine myself, but it's a 64 bits machine, and the code isn't 64 bit clean yet.
But I think it shouldn't be much work to get it to work on a 32 bits Solaris machine, if you are familiar with the build script. So I suggest you post me the actual problem here and I'll see what I can do. Or you could mail me (svdb at stack.nl).

Some other comments:
- Use the source from cvs, not the .tgz file from the download page. It's got a number of improvements.
- Compilation on gcc 3.4.x is broken at the moment. It can be worked around though.

Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!