The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
October 02, 2022, 05:33:10 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Problem compiling the latest CVS
« previous next »
Pages: [1] Print
Author Topic: Problem compiling the latest CVS  (Read 1715 times)
Spitfire
Zebranky food
*
Offline Offline

Posts: 9



View Profile
Problem compiling the latest CVS
« on: July 30, 2004, 11:34:50 pm »

I seem to have a strange compiling problem with the CVS source codes. I got the official 0.3 source compiled and running well in MS Visual C++ 6.0 after making sure the compiler finds all the required dll's and lib's, but now with the latest snapshot I get a linker error (actually I'm running the German version of Visual Studio so I translated the messages):

zip.obj : error LNK2001: unresolved external symbol __imp__inflate@8
zip.obj : error LNK2001: unresolved external symbol __imp__inflateInit2_@16
zip.obj : error LNK2001: unresolved external symbol __imp__inflateEnd@4
zip.obj : error LNK2001: unresolved external symbol __imp__inflateReset@4
../../uqmdebug.exe : fatal error LNK1120: 4 unresolved externals

I have no clue if there's something to be changed in zip.c to make it work, or if I've missed some setting in the compiler itself. My skills in C++ are very basic. Any insight where the problem lies?
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Problem compiling the latest CVS
« Reply #1 on: July 30, 2004, 11:47:44 pm »

People have reported things like this before on Windows.
I'm a Linux user myself, so I've never had the problem myself.
But if I recall correctly, it was always an issue of having the wrong zlib libraries. Downloading it from elsewhere worked. I don't remember the exact details; it may have had something to do with .dll and .lib mismatches, or with having multiple versions of zlib installed.
Our INSTALL file says to get the files from http://www.winimage.com/zLibDll/, so that's probably where you can download the correct one.
If that doesn't work, try getting it from http://www.gzip.org/zlib/.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Spitfire
Zebranky food
*
Offline Offline

Posts: 9



View Profile
Re: Problem compiling the latest CVS
« Reply #2 on: July 31, 2004, 12:08:00 am »

Thank you for your fast response!

You were right. I had the wrong version of zlib installed. I downloaded the version you suggested and with it the game compiled perfectly.

Thanks!  Smiley
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!