The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
October 24, 2019, 01:34:51 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  poor running performance
« previous next »
Pages: [1] Print
Author Topic: poor running performance  (Read 3089 times)
BlobbityBlob
Zebranky food
*
Offline Offline

Posts: 5


I love YaBB 1G - SP1!


View Profile
poor running performance
« on: September 09, 2004, 08:06:11 am »

The game's response to my keyboard inputs is quite sluggish.  It's especially bad in systems where there are a large number of orbiting starships (to the point that it's virtually impossible to guide my ship), but also noticeable in melee, in the lander (making mining a serious chore), and even in conversation with other species.  I'm running Windows XP on a PIII 700.  I'm also using the loader with the fullscreen setting, resolution on 320 x 240, and 16-bit color depth.

Using OpenGL gives me a blurry double-image.  Turing sound off or lowering sound quality doesn't help.

Any ideas?
Logged
Michael Martin
Core Team
*Smell* controller
*****
Offline Offline

Posts: 376



View Profile
Re: poor running performance
« Reply #1 on: September 09, 2004, 11:04:02 am »

Hmm.  What kind of graphics card?  We haven't really changed the internals much from back when I had a Celeron 500 running Windows 98, and that could handle the settings you described...
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: poor running performance
« Reply #2 on: September 09, 2004, 06:20:03 pm »

It's possible that there's a program in the background which is eating too much CPU time. Try to close as many programs in your system tray as possible.
Also, make sure you don't have any virusses or spyware.

Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
BlobbityBlob
Zebranky food
*
Offline Offline

Posts: 5


I love YaBB 1G - SP1!


View Profile
Re: poor running performance
« Reply #3 on: September 11, 2004, 12:52:45 am »

Well I closed all the applications I could and scanned for viruses/spyware (nothing showed up), with no improvement...any other ideas?
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: poor running performance
« Reply #4 on: September 11, 2004, 04:20:20 am »

Hmm... Another suggestion: make sure your video driver and directx are up-to-date.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
BlobbityBlob
Zebranky food
*
Offline Offline

Posts: 5


I love YaBB 1G - SP1!


View Profile
Re: poor running performance
« Reply #5 on: September 11, 2004, 07:21:07 am »

Yeah, they're fine....and I don't have problems running any other games but UQM.  It's a Radeon 7500.  I read something somewhere about setting the priority for command-line programs, but I couldn't figure out how to set it for UQM...maybe that might help?
« Last Edit: September 11, 2004, 07:30:06 am by BlobbityBlob » Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: poor running performance
« Reply #6 on: September 11, 2004, 08:24:11 am »

That has't been necessary for others on similar systems.
I'm running out of ideas.
Running in openGL shouldn't give you any blurry double-images either. I'd still place my bets on a video driver issue.
Is there anyone here on the board who has a Radeon 7500 too who can tell us his/her experiences?
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
BlobbityBlob
Zebranky food
*
Offline Offline

Posts: 5


I love YaBB 1G - SP1!


View Profile
Re: poor running performance
« Reply #7 on: September 11, 2004, 02:16:16 pm »

Well, I downloaded the current driver from ATI and still no help.  I thought the problem might be my cheap sound card but I have the same problem even with sound disabled.  Basically, I have to hold down any key I press for the program to respond, which results in 120 degree turns in spaceflight and "chunky" movement in general.  I can't even respond in the dialogue box without holding down 'enter' for about a second or so.  It's like the computer is way too slow or doesn't have nearly enough RAM, which I don't think is the case (700 mHz and 256 MB).

I really want to play this game, it was a favorite from back in the day.  Thanks for your help so far, but hopefully someone will come up with something that works.  Right now this makes absolutely no sense to me...
Logged
Defender
Enlightened
*****
Offline Offline

Gender: Male
Posts: 810



View Profile
Re: poor running performance
« Reply #8 on: September 11, 2004, 10:09:50 pm »

run these command lines, and not the loader.

-f -r320*240 -d32

tell me how it runs with that.

~DEFIANT
« Last Edit: September 11, 2004, 10:10:16 pm by DEFIANT » Logged
Megagun
Enlightened
*****
Offline Offline

Gender: Male
Posts: 580


Moo


View Profile
Re: poor running performance
« Reply #9 on: September 11, 2004, 11:56:20 pm »

You might try to clear up some disk space on the C-drive (or the one where windows is installed)

Also, you might want to unzip the 3 zips in UQM/content/packages to the UQM/content folder, and then remove them. I noticed that that slows the game down a bit on my 500mhz PC...

Trying to run the game without fullscreen might help, but I think you already tried that...
Logged
BlobbityBlob
Zebranky food
*
Offline Offline

Posts: 5


I love YaBB 1G - SP1!


View Profile
Re: poor running performance
« Reply #10 on: September 12, 2004, 12:39:10 am »

MegaGun: I extracted those files and it helped quite a bit, although it's still a bit chunky.  Thanks a bunch.

Defiant:  OK, I'm an idiot.  How exactly do I do that?

Thanks everyone for your help....
Logged
Megagun
Enlightened
*****
Offline Offline

Gender: Male
Posts: 580


Moo


View Profile
Re: poor running performance
« Reply #11 on: September 12, 2004, 01:05:33 am »

There's two ways of how you run the commandline thing..

1) create a shortcut to the exe file (rightclick -> create shortcut), then goto the shortcut's properties and add  -f -r320*240 -d32  to the location. Then, doubleclick the shortcut.
2) start->run and then run UQM with that commandline added to it, like:
"c:\program files\UQM\uqm.exe" -f -r320*240 -d32
Logged
Defender
Enlightened
*****
Offline Offline

Gender: Male
Posts: 810



View Profile
Re: poor running performance
« Reply #12 on: September 12, 2004, 04:45:45 am »

just as Megagun said. the reason i said not to use the loader, is that by default the "graphics scaling mode" is set to advanced bi adaptive.  this can easily tax your system. using the command lines i gave you, is low end system settings without all the "flashy" stuff. you could even change the -d32 to -d16. this changes the color depth. a lower setting may help here, but it causes problems with the graphics(at least on my system), so if it does, change it back to -d32.

also,when your using the Loader, check to see whats selected under "video": "graphics scaling mode'. if its "advanced bi adaptive", change the selection to "none". when i ran this on my older system, that setting caused all kinds of slow down.

let us know if that helps.

~DEFIANT
« Last Edit: September 12, 2004, 04:47:22 am by DEFIANT » Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: poor running performance
« Reply #13 on: September 12, 2004, 06:16:16 am »

Unzipping the content is a bad idea. You'll run into problems when you want to use add-on packs. And it will only save time when the game needs to load something, which isn't when your delays are occuring.

Also, running in a window is never faster than running full-screen, and in fact it's usually significantly slower. If you do insist on running in a Window, make sure that the bit depth in the Windows display settings is not set to 24 (16M colours). 32 (4.2B colours) is fine, 16 (65536) is fine too, but 24 bpp is an inefficient mode. This is not specific to UQM.

« Last Edit: September 12, 2004, 06:16:44 am by meep-eep » Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!