The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
October 05, 2022, 03:37:05 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Not launching in OSX
« previous next »
Pages: [1] Print
Author Topic: Not launching in OSX  (Read 1851 times)
Duffy
Zebranky food
*
Offline Offline

Posts: 4


I love YaBB 1G - SP1!


View Profile
Not launching in OSX
« on: October 05, 2004, 06:56:22 pm »

Wonder if anyone else had had this. Downloaded this great project yesterday, and it worked a treat. Great job guys! However, I had to quit, and when I tried to fure it up today, I get the preference panel up, but when I hit launch, it just dies. A new UQM icon appears briefly in the dock then vanishes. I have re-booted, deleted and re-installed, all with no luck. Are there some other files lurking somewhere that I may have corrupted? Any help appreciated
Logged
Nic
Guest


Email
Re: Not launching in OSX
« Reply #1 on: October 05, 2004, 07:33:05 pm »

First and foremost, get/install the updated Launcher and game binary from here:

http://www.submedia.net/uqm/

...that may correct your problems all on its own.  If not, open the Finder, and hit Shift-Command-G; in the dialog that appears, enter /tmp  You should see a file in the window that appears named uqm.out, open it in TextEdit and see if it contains any interesting error messages.
Logged
Duffy
Zebranky food
*
Offline Offline

Posts: 4


I love YaBB 1G - SP1!


View Profile
Re: Not launching in OSX
« Reply #2 on: October 05, 2004, 07:57:23 pm »

Thanks for the reply!
Got the new launcher, no change. The log file has an error listed

/Applications/The Ur-Quan Masters.app/Contents/MacOS/uqm: invalid option -- l
argv[0] = [/Applications/The Ur-Quan Masters.app/Contents/MacOS/uqm]
argv[1] = [--contentdir=/Applications/The Ur-Quan Masters.app/Contents/Resources/content]
argv[2] = [-l]
argv[3] = [/tmp/uqm.out]

I have no idea what this means though
Logged
Nic
Guest


Email
Re: Not launching in OSX
« Reply #3 on: October 05, 2004, 08:08:35 pm »

Right.  The updated launcher requires the updated game binary as well.  Install both and try it again.

(I should probably combine them into some manner of unified installer.  A little AppleScript goes a long way sometimes...)
Logged
Duffy
Zebranky food
*
Offline Offline

Posts: 4


I love YaBB 1G - SP1!


View Profile
Re: Not launching in OSX
« Reply #4 on: October 05, 2004, 08:33:15 pm »

Apologies for being spectacularly thick, but where do I get the binary from?
Logged
Duffy
Zebranky food
*
Offline Offline

Posts: 4


I love YaBB 1G - SP1!


View Profile
Re: Not launching in OSX
« Reply #5 on: October 05, 2004, 09:18:37 pm »

Note to self : Rad the mails properly

Works perfectly now, cheers for all the help. Really appreciate it!
Logged
Nic
Guest


Email
Re: Not launching in OSX
« Reply #6 on: October 08, 2004, 03:44:39 pm »

Quote
(I should probably combine them into some manner of unified installer.  A little AppleScript goes a long way sometimes...)

This is now done; which should hopefully make things easier on future generations of Mac users.  Of course, since you already updated your files, it won't do you any good, but you're still welcome to try it if you like.  Wink
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!