The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
October 06, 2022, 08:45:58 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Mac OS X - missing .mod music
« previous next »
Pages: [1] Print
Author Topic: Mac OS X - missing .mod music  (Read 2138 times)
fluffy
Zebranky food
*
Offline Offline

Gender: Female
Posts: 5


meep


View Profile WWW
Mac OS X - missing .mod music
« on: March 19, 2005, 09:50:33 pm »

Hi, on the OSX version, while the music which is available in .ogg format plays great, the rest of it (comms music, battle victory fanfares, etc.) do not.  MikMod seems to be loading the songs just fine according to /tmp/uqm.log, however, but when it actually tries to play the songs I get messages like this:

Found timestamp file: comm/urquan/urquan.ts
       'comm/urquan/urquan.mod' -- 75885 bytes
_GetMusicData(): loading comm/urquan/urquan.mod
   decoder: MikMod, rate 44100 format 170202
SpliceTrack(): loading comm/urquan/urqua027.ogg
SoundDecoder_Decode(): eof for comm/urquan/urqua027.ogg
Switching to stream comm/urquan/urqua027.ogg at pos 63371

Why is it trying to play a (non-existent) .ogg file when the .mod file is actually there?

I have the stock 0.3 DMG installed, with the latest versions of uqm-0.3-3domusic.zip and uqm-0.3-voice.zip.  (Voice works just fine, so I know they're installed in the right place.)

Any ideas?

Thanks in advance.
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Mac OS X - missing .mod music
« Reply #1 on: March 19, 2005, 10:17:06 pm »

Quote
Why is it trying to play a (non-existent) .ogg file when the .mod file is actually there?

comm/urquan/urqua027.ogg is a speech file, so that's not the problem. Are you using OpenAL or MixSDL sound? Have you tried the latest CVS build?
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
fluffy
Zebranky food
*
Offline Offline

Gender: Female
Posts: 5


meep


View Profile WWW
Re: Mac OS X - missing .mod music
« Reply #2 on: March 19, 2005, 10:38:44 pm »

I'm using MixSDL, and I'd be running the CVS version if I could find any instructions on how to get it.  The site is a bit lacking in that regard.
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Mac OS X - missing .mod music
« Reply #3 on: March 19, 2005, 11:15:52 pm »

This sounds similar to bug 523 and bug 166. Try setting sound quality to medium.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
fluffy
Zebranky food
*
Offline Offline

Gender: Female
Posts: 5


meep


View Profile WWW
Re: Mac OS X - missing .mod music
« Reply #4 on: March 19, 2005, 11:42:26 pm »

That fixed it, thanks.
Logged
0xDEC0DE
*Many bubbles*
***
Offline Offline

Posts: 175



View Profile WWW
Re: Mac OS X - missing .mod music
« Reply #5 on: March 20, 2005, 01:25:02 am »

CVS version for OSX is right here.  This info also happens to be in the very first entry of the FAQ.
Logged

"I’m not a robot like you. I don’t like having disks crammed into me… unless they’re Oreos, and then only in the mouth."  --Fry
fluffy
Zebranky food
*
Offline Offline

Gender: Female
Posts: 5


meep


View Profile WWW
Re: Mac OS X - missing .mod music
« Reply #6 on: March 20, 2005, 02:04:51 am »

As a suggestion, maybe the FAQ should be linked somewhere more visible, since when I looked for one, all I found was http://sc2.sourceforge.net/info.php#faq (I did check the wiki but it also wasn't immediately obvious where the FAQ was in there either; it just looked like gameplay hints, and so I didn't even notice the FAQs link).

Also, I did look around for bug reports on this before I posted a question to the forum, but I couldn't find the bug tracker either - I only saw the forum, and had searched that.

The UQM site could be laid out a bit more clearly.
« Last Edit: March 20, 2005, 02:06:21 am by fluffy » Logged
0xDEC0DE
*Many bubbles*
***
Offline Offline

Posts: 175



View Profile WWW
Re: Mac OS X - missing .mod music
« Reply #7 on: March 20, 2005, 02:57:28 pm »

I see.  Would locking a post called "Frequently Asked Questions" at the top position of each forum make them any easier for you to find?

Oh, wait, they already do that.

How about linking to the FAQs from the main page of the Wiki, and linking to the Wiki from the project pages?  Would that help?

Oh, wait, they already do that, too.  See that giant grain of salt?  I'm taking your criticisms with it.

If you've got a better idea for the layout of the Wiki, then I've got great news -- it's a Wiki.  Anyone and everyone is free to edit it however they like, so if you have a better idea on how to do it, then by all means, please go make it happen.
Logged

"I’m not a robot like you. I don’t like having disks crammed into me… unless they’re Oreos, and then only in the mouth."  --Fry
fluffy
Zebranky food
*
Offline Offline

Gender: Female
Posts: 5


meep


View Profile WWW
Re: Mac OS X - missing .mod music
« Reply #8 on: March 20, 2005, 03:22:50 pm »

All I'm saying is that it should be linked better from the site itself, rather than requiring people who aren't familiar with every aspect of the community to go hunting around.  There is no need to be rude.

Anyway.  The original question I had was answered, and I'm grateful for the assistance.
« Last Edit: March 20, 2005, 03:24:02 pm by fluffy » Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!