The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
December 10, 2022, 06:53:50 am
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Problems with new characters
« previous next »
Pages: [1] Print
Author Topic: Problems with new characters  (Read 4179 times)
Volka
Frungy champion
**
Offline Offline

Gender: Male
Posts: 78



View Profile WWW
Problems with new characters
« on: July 21, 2005, 08:40:54 pm »

I'm in the middle of the process of translating the game to spanish and it is needed to add some new characters to the fonts.

I've read the threads about how to do this, however it doesn't seem to work for me, maybe I'm doing something wrong.

These are the steps I did to add a character,for example the begining exclamation mark¬  (¬°)

1. Took a copy of the 33.png file (the exclamation mark !) and rotated it so that it looks like ¬°
2. Then, looked up into to the Unicode charts inside Latin-1 (U0080.pdf)¬  and found that the character hexadecimal code is 00A1.
3. Made the conversion to decimal number (http://www.statman.info/conversions/hexadecimal.html) and got the number 161.
4. Renamed the new character file as161.pgn and place it in the comandr.fon folder.
5. Added some exclamation marks in the conversation text file and saved it in UTF-8¬  encoding (just by using Notepad, but also I tried a program called "Unifer" and got the same results)
6. When I run the addon and go the the Starbase, the game screws up and Commander Haydes asks me" Did you find any radioactive elements for our energy cores?". The answers are also screwed and the text and the sound files don't match correctly.

What's wrong then?
« Last Edit: July 21, 2005, 09:57:29 pm by Volka » Logged

UQM in spanish:
Here
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Problems with new characters
« Reply #1 on: July 21, 2005, 09:32:04 pm »

Sounds like your text file is messed up. Probably a blank line in the wrong place or some other extraneous garbage. If Notepad is placing a byte order marker (BOM) at the beginning of the file, remove it. Lopping the first three bytes off with a hex editor should do the trick. See also here.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Volka
Frungy champion
**
Offline Offline

Gender: Male
Posts: 78



View Profile WWW
Re: Problems with new characters
« Reply #2 on: July 21, 2005, 09:55:34 pm »

Ah, evil Notepad!
I tried with TextPad and now it works.

Thanks dude :)
Logged

UQM in spanish:
Here
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!