The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
December 05, 2022, 11:49:05 am
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Two Bugs - Pause and Mineral Offload Speed
« previous next »
Pages: [1] Print
Author Topic: Two Bugs - Pause and Mineral Offload Speed  (Read 2412 times)
serendipity
Zebranky food
*
Offline Offline

Posts: 16


Personal text is for weenies.


View Profile
Two Bugs - Pause and Mineral Offload Speed
« on: December 13, 2002, 04:25:46 am »

Two bugs I couldn't find in the lists or forums:

Offloading minerals takes a random amount of time it seems.  About 50% of the time, it's instant - I don't even see the animation for going through the list of minerals and counting them down (but I know it's playing the animation, as I can occasionally see a frame or two of the countdown display).  The other 50% of the time, it's normal - I can see the full animation at "normal" speed.
Can't figure out what makes it one way or the other.  This is on my laptop that I see the 50/50 behavior - PIII 850, 256MB RAM, Windows XP, using the CVS version.   On my desktop, Athlon 2200, 512MB RAM, Windows 2000, running the Alpha, I only saw the "instant" behavior, but that may have been coincidence.


Also, it's been mentioned, but not as its own topic.  You can pause the game, but can't unpause it.  Oddly, this doesn't happen when I build the debug version, only with the Win32 Release version.  With the debug build, F1 pauses and unpauses.  With the release build, F1 pauses, but the only key that the game responds to afterwards is ~, to exit.  Haven't been able to figure out where the problem is, as it's tough to debug without debugging information.
Logged
SLot0k
Zebranky food
*
Offline Offline

Gender: Male
Posts: 7



View Profile WWW
Re: Two Bugs - Pause and Mineral Offload Speed
« Reply #1 on: December 13, 2002, 06:42:57 am »

I can confirm that the pause button does not unpause in the win32 v0.12 version. Win98se, 128M RAM.

I guess I'll have to start a conversation when I need a beer!  Grin
Logged
miri
Guest


Email
Re: Two Bugs - Pause and Mineral Offload Speed
« Reply #2 on: December 13, 2002, 02:41:25 pm »

confirming the offloading speed thing.
It seems to be more probable to happen instantly when I have a lot of exotic minerals (the 25RU things).
Logged
Nic.
Guest


Email
Re: Two Bugs - Pause and Mineral Offload Speed
« Reply #3 on: December 13, 2002, 10:06:55 pm »

I've got a theory on where to start looking, but let's see if my ideas on "what's going on" pan out:

If it's going at "normal speed" and you hit Enter, does it go into fast-forward mode?  Give it a shot..
Logged
EoRaptor
Guest


Email
Re: Two Bugs - Pause and Mineral Offload Speed
« Reply #4 on: December 14, 2002, 01:31:41 am »


The mineral offload bug happens as follows:

If you offload minerals as the very first action after selecting 'starbase commander' it'll happen at 'normal' speed.
If you talk to the commander about anything else first, mineral offload is instant.
Logged
TD
Frungy champion
**
Offline Offline

Gender: Male
Posts: 55



View Profile
Re: Two Bugs - Pause and Mineral Offload Speed
« Reply #5 on: December 14, 2002, 03:17:09 am »

Sorry but you're wrong EoRaptor.

The offloading minerals bug happens when you hit enter hard or hold it down when selecting to offload minerals which means it is being dectected while the offloading is in progress and skips it.

It should really only skip if you hit enter again. Something to add to the bugs list anyway Smiley
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!