The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
January 22, 2021, 05:22:58 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Audio Stutter
« previous next »
Pages: [1] Print
Author Topic: Audio Stutter  (Read 2378 times)
TechMage89
Guest


Email
Audio Stutter
« on: September 14, 2005, 11:12:22 pm »

Whenever I play the game, I constantly get sttuter in the voice and music. Sometimes the stutter is short, cutting out only a single syllable of a speech, sometimes it cuts out for as much as 10 seconds. I have tried using default and OpenAl audio settings. My computer runs Windows XP, and I have a Sound Blaster Live sound card.
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Audio Stutter
« Reply #1 on: September 15, 2005, 12:29:51 am »

Assuming you've got a reasonably modern computer, I suggest you close all other programs (in the system tray too) that may be requiring CPU time periodically. A virus scanner doing a system scan in the background perhaps. If that's not helping, it may be a program that you don't *know* is active on your computer, in other words, spyware, virusses, and other malware. Scanning your system for virusses or spyware may help in that case.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
TechMage89
Guest


Email
Re: Audio Stutter
« Reply #2 on: September 15, 2005, 04:51:23 am »

It's not spyware, I regularly clean with both the microsoft beta and spybot, as well as checking for unusual processes. This does not appear to be a performance problem, as changing options on scalars, etc. does not seem to have an effect. I noticed the last time I played using OpenAL, it said that it was using software accelleration, when the OpenAL website says  that the SB Live should be able to use OpenAL in hardware mode. Presumably, on a 2ghz system with 512 megs of ram, this game should be no problem performance wise.

Just a side note: I have also noticed that audio emulation programs (like VDMsound) don't seem to like my computer, and dosbox hardly works at all with audio. For some reason my computer won't do software audio emulation properly.
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Audio Stutter
« Reply #3 on: September 15, 2005, 10:19:13 am »

This sounds like a sound driver problem. Microsoft's drivers tend to lack a lot of features, so you'd be better off using the latest version of Creative's drivers.

In my experience, audio problems of this magnitude are usually due to other processes interfering. I've experienced intermittent sound problems similar to yours when running Ahead InCD. You should particularly look for processes that periodically perform some operation, especially one that requires some form of hardware locking or other heavy resource use. Windows Task Manager is a good tool for this. Note that even a very small CPU use does not mean the program isn't causing something else to block, so it is possible that you've missed the real culprit when checking for interfering processes.

However, I have also experienced problems with SB Live cards that occur on several different Windows and driver versions, machines and cards; the SB Live simply seems to be incompatible with a large number of motherboards. Via boards in particular cause problems and upgrading your motherboard drivers may help in this case. Decreasing PCI bus latency may also help (if your BIOS supports this).
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Audio Stutter
« Reply #4 on: September 15, 2005, 03:21:01 pm »

Oh, you're using OpenAL. The OpenAL library is full of bugs. It's really not production ready. On Linux it's even worse. I suggest you stick to MixSDL. It doesn't support positional audio, but at least it works.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
TechMage89
Guest


Email
Re: Audio Stutter
« Reply #5 on: September 15, 2005, 10:58:16 pm »

As I said, the problem occurs with both audio drivers.
I was already using Creative's drivers, as the Microsoft ones work poorly because my card is the Dell edition.

However, I was able to find an interesting solution, if a temporary one. I remembered that I had an Audigy card sitting around, which I had not installed because it was missing the addon unit with the midi port. I installed it, and the problem stopped. Unfortunately, in addition to having no midi port, It will not connect to the microphone jack on the front of my Dell. I would like a better solution, but perhaps I will simply have to buy a new sound card.

I still wonder, however, why OpenAL (with both cards) says its using software accelleration. Don't my cards support hardware accelleration with OpenAL?
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Audio Stutter
« Reply #6 on: September 16, 2005, 12:49:07 pm »

If you have enough PCI card slots, you can hook up both sound cards. You'll just have to tell Windows to only use the Audigy for sound output and use the Live for MIDI and microphone.

As Meep-eep mentioned, OpenAL has so many problems right now (under Windows especially) that you're lucky if it works at all. I doubt there's anything seriously wrong with your system (apart from the design faults of the SB Live).
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!