The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
August 14, 2022, 12:21:34 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  No more AL_DATA?
« previous next »
Pages: [1] Print
Author Topic: No more AL_DATA?  (Read 1825 times)
bpoint
Zebranky food
*
Offline Offline

Gender: Male
Posts: 13



View Profile WWW
No more AL_DATA?
« on: January 28, 2006, 08:45:21 am »

It seems that with OpenAL-0.0.8, support has been dropped for AL_DATA.  The enum no longer exists in al.h.  With the latest CVS, this means that audiodrv_openal.c (line 72) doesn't compile.

I tested UQM with this line set to zero and it _seemed_ to work fine.  I was able to change the driver to OpenAL and use positional sound without a problem.  But I don't quite know how the sound system works in UQM, so I'm not in any position to say if it's a safe fix or not.

I'll be using the SDL driver myself, but I just wanted to give everyone a heads up...
Logged
fossil
Core Team
Frungy champion
*****
Offline Offline

Gender: Male
Posts: 94



View Profile
Re: No more AL_DATA?
« Reply #1 on: January 30, 2006, 12:55:44 pm »

Thanks for the heads up. We will simply remove AL_DATA from UQM audiocore. It is not being used anyway.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!