The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
August 10, 2022, 07:10:36 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Refresh rate in fullscreen mode...
« previous next »
Pages: [1] Print
Author Topic: Refresh rate in fullscreen mode...  (Read 2076 times)
Jagular~
Guest


Email
Refresh rate in fullscreen mode...
« on: April 11, 2006, 12:20:45 pm »

My computer:

P-III 1266, ATI RadeOn-8500, 512RAM, lots of HD, win-98SE, ie 6.1.x

Line of parameters:

uqm.exe --addon remix --addon uqmremix -o -r 1280x960 -f -M 100 -S 100 -T 100 -q high --cscan pc --menu pc --font pc

Since 0.5.0 I've got the following problem (0.3.0 and 0.4.0 worked fine):
In fullscreen mode UQM runs only in 60Hz refresh mode in all resolutions... I've managed to solve it by setting precise value (in this example - 85Hz) instead of Optimal Refresh Rate setting in Display Properties for the graphic-mode that I use in command line of UQM, but this parameter makes almost all other fullscreen games set RR to 60Hz... :-( So, I have to play UQM in window...
Is there some kind of undocumented parameter that can fix RR in FS? I couldn't find anything about it in documentation...
I've tried various scale methods (just to check if this is my video driver bug), tried to on/off OpenGL... Nothing helped... Is such behaviour a bug and I should report it to bugDB?

And one more question... Readme.txt says that line-parameter that forced bitdepth of the screen is gone now... Do you have plans to get it back in another form or this rather useful feature is lost forever?
Logged
Michael Martin
Core Team
*Smell* controller
*****
Offline Offline

Posts: 387



View Profile
Re: Refresh rate in fullscreen mode...
« Reply #1 on: April 16, 2006, 07:48:18 pm »

The bit depth parameter was mainly good for causing mysterious hardware crashes, so we switched to an autodetect.  If you want to force a bit depth, set it globally and 0.5.0 should match it.

It's a bit baffling that setting it to 85Hz would force 60Hz elsewhere.

That said, refresh rate isn't one of the things we deal with directly at all; I suspect this has something to do with SDL.
Logged
Jagular~
Guest


Email
Re: Re: Refresh rate in fullscreen mode...
« Reply #2 on: April 18, 2006, 09:56:01 am »

Well, thank you for an answer... Guess, I'll have to use 3rd party soft to set refrate for the UQM game session... BTW, reschange helps to avoid this problem (http://12noon.com/reschange.htm)...
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!