The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
August 08, 2022, 02:54:15 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  UQM 0.6.2 Netplay Connection Problem
« previous next »
Pages: [1] Print
Author Topic: UQM 0.6.2 Netplay Connection Problem  (Read 2146 times)
Valaggar
Guest


Email
UQM 0.6.2 Netplay Connection Problem
« on: April 01, 2007, 03:07:45 pm »

I tried to netplay with Elvish Pillager for three times.
The first time (some months? ago) it worked.
The second and the third time (separated by a few weeks) it did not work - no connection could be established, though no error message appeared.
The port 21837 or whatsit is properly forwarded etc.; there are no addons besides the Super Melee remix.

Related to this - if someone tries to connect to a fullscreen minimized UQM, the connection works or not? (this may be the cause)
Logged
Valaggar
Guest


Email
Re: UQM 0.6.2 Netplay Connection Problem
« Reply #1 on: April 02, 2007, 03:36:42 pm »

No, fullscreen is not the problem.
I tried with Galactic (I connected to him) and it... worked, although the lag was WAY too high to be playable (so I couldn't play), no matter the net delay.
However, if someone tries to connect to me, nothing happens. Absolute Zero.
Related to lag, I played once with Elvish with an acceptable lag (he connected to me).
Logged
Valaggar
Guest


Email
Re: UQM 0.6.2 Netplay Connection Problem
« Reply #2 on: April 02, 2007, 03:54:01 pm »

This port is forwarded:
Inside IP: (my external IP address)
Outside IP: (my external IP address)
Inside Port: 21837
Outside Port: 21837
Protocol: tcp

And it says that the entry is of type "stat" and is continually in state "SYN_RECV".

Should I use 0.0.0.0 as Outside IP?
In that case the entry is of type "temp" and is not in "SYN_RECV" (it's normally in "NONE")

In fact, I had both entries at the same time always when it didn't work, I've just discovered (I don't know if I had them so before).
Should I use only the 0.0.0.0 outside IP entry?
Logged
Koowluh
*Smell* controller
****
Offline Offline

Gender: Male
Posts: 382



View Profile
Re: UQM 0.6.2 Netplay Connection Problem
« Reply #3 on: April 02, 2007, 05:02:59 pm »

That's how my router works as well. I fill in 0.0.0.0 as the outside address and it works like a charm. Your inside ip address should be the one of the computer you're running UQM on though (can be found with the command ipconfig)
Logged

I hate drugs. Air is the worst one. Breathe it once and you're hooked for life.
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: UQM 0.6.2 Netplay Connection Problem
« Reply #4 on: April 02, 2007, 05:07:55 pm »

This port is forwarded:
Inside IP: (my external IP address)
Outside IP: (my external IP address)
Inside Port: 21837
Outside Port: 21837
Protocol: tcp
"Inside IP" should probably be your internal address. I'm assuming that's a typo in the following.

Quote
And it says that the entry is of type "stat" and is continually in state "SYN_RECV".

Should I use 0.0.0.0 as Outside IP?
In that case the entry is of type "temp" and is not in "SYN_RECV" (it's normally in "NONE")

In fact, I had both entries at the same time always when it didn't work, I've just discovered (I don't know if I had them so before).
Should I use only the 0.0.0.0 outside IP entry?
Exactly what sort of firewall are you using? It's hard to tell what's wrong without that information, especially since the meanings of special values like 0.0.0.0 are going to be different on different systems. In this case it's also hard to say whether "Outside IP" refers to the external address of the firewall or the (external) address of the connecting peer (the fact that the connection somehow jumps to SYN_RECV could imply the latter, but I'm just guessing since I don't know whether the TCP state you mention is from the firewall or the host behind it (or indeed whether they are separate!)).

If you could describe your setup first, someone may be able to help. Alternatively, you could try switching "Outside IP" to 0.0.0.0 or the address of the machine that you want to allow to connect.

You can use a telnet client (or netcat) as a sort of generic testing tool for this sort of thing if you don't want to go through the hassle of setting up UQM at a remote location. I personally just do:
Code:
telnet <my external address> 21837
from my Linux box at work to test my firewall config, with UQM hosting a game. If the telnet client connects, it's instantly visible in the server. If it fails to connect, something is wrong. Starting telnet on a remote machine is much easier than starting UQM.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Valaggar
Guest


Email
Re: UQM 0.6.2 Netplay Connection Problem
« Reply #5 on: April 02, 2007, 06:03:32 pm »

Thanks for help, it's enough.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!