The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
September 25, 2022, 06:28:42 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Can't play in full screen?
« previous next »
Pages: [1] Print
Author Topic: Can't play in full screen?  (Read 1697 times)
Teibidh
Zebranky food
*
Offline Offline

Posts: 1



View Profile
Can't play in full screen?
« on: April 14, 2007, 06:39:44 am »

I'm not really even sure what caused this, I don't think I updated any system files, but:

Play on Kubuntu AMD64 Feisty (Linux) using ATI proprietary drivers (FGLRX).
Everything was working wondefully last night, playing at 1024x768 with HQ rendering options ... as one would expect from a PCI Express card and a relatively simple graphics engine, there were no performance issues... mind you, I play in Full Screen.

Today, I launch the game and I get no video output ... If I change the game (editing uqm.cfg) to use windowed mode (FullScreen=no) then it works... it's just small Tongue It's worth noting that the game engine does launch, I hear audio response from it when I press arrow keys and the menu is responsive because I can hit the up arrow and then enter to quit the game.... just no display.

Of note, the only difference in std output that I see when in fullscreen and not in windowed mode is this message:

Code:
Thread 'flash rectangle' blocking on 'DCQ'

Which is different from the spam I normally get:

Code:
Thread 'Unknown (probably renderer)' blocking on 'DCQ'

Any thoughts?
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Can't play in full screen?
« Reply #1 on: April 14, 2007, 11:10:02 am »

Have you tried switching from windowed to fullscreen mode while in game? Have you tried fullscreen at a lower (or higher; same as your desktop) resolution? In particular, does 640x480 (with SDL framebuffer mode) work?

Does your monitor receive a valid signal in fullscreen (can it, for example, identify the resolution and refresh rate used correctly)? If not, check your X11 configuration and/or try a different resolution. If the monitor is getting a valid signal (but it's just plain black), something weird is going on (OpenGL should work exactly the same in all resolutions in X11!); try setting environment variable SDL_VIDEODRIVER to x11 before running and see if that makes a difference. Similarly, try setting SDL_VIDEO_X11_XRANDR to both 0 and 1 and see if that affects the problem.

If you have multiple monitors, make sure all but one are disabled.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!