The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
September 25, 2022, 08:03:59 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Trouble with UQM 0.6.2
« previous next »
Pages: [1] Print
Author Topic: Trouble with UQM 0.6.2  (Read 2571 times)
Zarnium
Frungy champion
**
Offline Offline

Gender: Male
Posts: 75


Mr. Owl ate my metal worm.


View Profile
Trouble with UQM 0.6.2
« on: July 07, 2007, 12:08:18 am »

I have Mac OS X, and I can't play Super Melee at all  because it's really choppy and has a bad framerate. The music is really jittery, too. Any help?
Logged

Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Trouble with UQM 0.6.2
« Reply #1 on: July 07, 2007, 12:59:51 am »

Bad performance checklist:
  • Check for resource-intensive (CPU and memory in particular) background processes and stop them.
  • Turn graphics filters (scalers) off (or maybe to bilinear).
  • Switch to MixSDL if using OpenAL.
  • If using pure SDL graphics, switch to OpenGL or vice versa (choose whichever seems to work best).
  • Decrease graphics resolution (down to 640x480 or 320x240).
  • Decrease sound quality.
If none of the above help, there's something very wrong somewhere.

Based on your machine specs as posted in the offtopic section, UQM should work decently with the right settings. I'm posting this on a 500 MHz Pentium 3 with 448 MB RAM and an NVidia Riva TNT graphics adapter running UQM in 640x480 (24 bit colour) in pure SDL mode with bilinear filtering and high quality sound under OpenSUSE 10.2; speed looks OK as far as I can tell. YMMV.
« Last Edit: July 07, 2007, 01:19:29 am by Novus » Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Zarnium
Frungy champion
**
Offline Offline

Gender: Male
Posts: 75


Mr. Owl ate my metal worm.


View Profile
Re: Trouble with UQM 0.6.2
« Reply #2 on: July 07, 2007, 01:34:32 am »

Goodness, I did decrease the sound quality and graphics resolution, but it made the screen really tiny and I couldn't even start super melee because it wouldn't let me select a ship. even weirder, the default setting for the bottom ship roster was awesome cyborg and the top was Human Control. also, I still have version 0.5 on my computer, which is working perfectly fine, except for the fact that the top ship roster is permanantly set on Human control. However, when you start a battle the computer plays the second player like it's on awesome cyborg. version 0.5 was working fine until I got version 6.2. I would just delete both of them and just download 0.5 to see if that works, but version 0.5 doesn't seem to be available for download anymore.

I guess my computer is really messed up Huh?

Logged

Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Trouble with UQM 0.6.2
« Reply #3 on: July 07, 2007, 02:09:15 am »

If you can't change settings properly any more, something is really wrong (switching back to an older version of UQM is seldom a good idea). I suggest you remove all previous installations of UQM, including configuration files (you can keep the saved games), and reinstall 0.62.

Decreasing the resolution is going to make the window UQM uses smaller. In fullscreen mode, the screen resolution should decrease to match the resolution UQM uses, ensuring the screen stays filled (assuming SDL behaves the same on OS X as everywhere else).
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Zarnium
Frungy champion
**
Offline Offline

Gender: Male
Posts: 75


Mr. Owl ate my metal worm.


View Profile
Re: Trouble with UQM 0.6.2
« Reply #4 on: July 07, 2007, 02:18:05 am »

I was in full screen mode, but there was just a lot of black around the screen.
Logged

Amiga_Nut
*Many bubbles*
***
Offline Offline

Gender: Male
Posts: 208



View Profile
Re: Trouble with UQM 0.6.2
« Reply #5 on: July 07, 2007, 06:46:25 am »

You need to describe your hardware a little better.
Logged

I keep my old Amiga on a flash-drive. Tongue

Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Trouble with UQM 0.6.2
« Reply #6 on: July 07, 2007, 11:48:34 am »

I was in full screen mode, but there was just a lot of black around the screen.
OK, so OS X didn't turn the display resolution down enough. Any Mac user here know how to set up 320x240 on a Mac (specifically, Zarnium's Mac)?
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
0xDEC0DE
*Many bubbles*
***
Offline Offline

Posts: 175



View Profile WWW
Re: Trouble with UQM 0.6.2
« Reply #7 on: July 07, 2007, 05:44:48 pm »

On my old 600MHz G3 iBook, UQM barely ran at an acceptable rate when turning off all scaling, and knocking the sound quality down to "low".  Full-screen mode also murdered the performance, which is odd because in windowed mode, the OS does double-buffering on all windows, and full-screen actively disables that behaviour.

It's entirely possible that your machine is just too slow to run the game.  But given what I know about the performance bottlenecks in the game on OSX (which ain't much, mind you) I'd start by disabling all audio and scaling, and go from there.
Logged

"I’m not a robot like you. I don’t like having disks crammed into me… unless they’re Oreos, and then only in the mouth."  --Fry
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Trouble with UQM 0.6.2
« Reply #8 on: July 10, 2007, 03:01:07 pm »

What file was that?
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!