The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
October 07, 2022, 11:30:26 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Oscilloscope problem with MixSDL
« previous next »
Pages: [1] Print
Author Topic: Oscilloscope problem with MixSDL  (Read 1484 times)
Daniel
Guest


Email
Oscilloscope problem with MixSDL
« on: January 30, 2003, 03:18:46 am »

With the new MixSDL code, I can finally get an oscilloscope.  However, I have noticed an odd bug in the oscilloscope.  As the sound plays, the oscilloscope becomes jerkier and jerkier -- rather than jumping wildly as it did at the beginning of the speech, it only updates one or two times per second.

The CPU usage of uqm is negligible during the whole time the speech is being played.  (ie, my CPU is 90-99% idle)  Sometimes when this happens it appears that the oscilloscope becomes slower each time a new page of text is displayed, but I'm not sure about that.

My computer is an Athlon tbird (1.2GHz) with an ES1969 sound card.  I'm running on Debian unstable with a 2.4.20 kernel, and using the ALSA sound drivers.

Daniel
Logged
Daniel
Guest


Email
Re: Oscilloscope problem with MixSDL
« Reply #1 on: January 30, 2003, 10:28:00 pm »

I can't reproduce this any more with today's CVS.  It appears to be fixed.

Daniel
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!