The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
November 25, 2020, 07:05:52 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  A few more bugs
« previous next »
Pages: [1] Print
Author Topic: A few more bugs  (Read 3302 times)
Death 999
Global Moderator
Enlightened
*****
Offline Offline

Gender: Male
Posts: 3848


We did. You did. Yes we can. No.


View Profile
A few more bugs
« on: February 03, 2003, 08:13:46 pm »

All of these bugs are on the Mac OS 10.1.2, with he uqm version that Nic. is hosting.

1) I wish to extend the "too fast combat when engaging slylandro while in autopilot" bug to lwrath as well.

2) when proceeding out of a star system on autopilot, during each of the zoom transitions the starmap flashes onto the screen. I don't mind, but thought you should be aware.

3) In conversation with Fwiffo, the image for his eye sometimes obscured part of his eye stalk.

4) whenever I maneuver in a star system with other fleets around, movement is VERY choppy.

5) I never hear the first speech segment in a conversation. I cannot rewind to it. This is compounded by my not knowing how (if in fact it is possible) to advance the text manually. In short conversations where I never get an opportunity to reply (think of the surveillance drone), this is really bad since I only see the first page of text on the screen for a few seconds, then it disappears and I never get to hear anything or even see the rest.

6) It seems that massive tectonic barrages preferentially occur when the lander is landing. Hard to notice on some planets, but on others I would land and freak out, then things would calm down and stay calm for a long time. Then there would be a lot of earthquakes again all at once... this is probably intended behavior (earthquakes DO tend to cluster in real life), but timing them to start when the lander comes down doesn't make sense. It WOULD make sense with the weather though.

7) at start of hyperspace, the spinning up is choppy. After that things are much smoother (though I can notice that once per second glitch quasi-subliminally)

good luck! Any clarifications and I'll be glad to help.
Logged
Nic.
Guest


Email
Re: A few more bugs
« Reply #1 on: February 03, 2003, 11:09:40 pm »

The slow/choppy video can (I believe) be linked to the fact that the version I'm hosting was built with "pure SDL" only -- no OpenGL support.  On my Debian box, "pure SDL" mode achieved a "passably low" FPS score, (it was nowhere NEAR as bad as non-accelerated OpenGL, however) and I have little trouble seeing how it could have a bit of trouble keeping up with lots of movement onscreen.

Mr. McNamara has promised that the next build will be statically linked, and provide OpenGL support, thus making it playable by all, and good-looking to boot.  As I have no access to OSX personally, I can not be of any real assistance in this matter.  Sorry.
Logged
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: A few more bugs
« Reply #2 on: February 04, 2003, 12:47:05 am »

Hey--

I built the version you are using, and we have since figured out a way to fix the choppiness/skipping stuff, but I have been asked not to patch the interim release version until the bug has been fixed properly.  Pleasse rest assured that upon the release of the .2 version, a new version will be available that solves (at least in testing on my machine) all of the speed issues.


More of concern to me is the fact that one cannot escape from battle as of right now... or if you can, I cannot figure out how.  Have tried the prescribed key combinations.  If you have managed to, please let me know so I can include it in the OS X Readme.


Enjoy, and hang in there,

Robert McNamara
Logged
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: A few more bugs
« Reply #3 on: February 04, 2003, 01:00:52 am »

Oh, right, and one more thing...

The version currently up at Nic's web site *is* built with OpenGL support...  That shouldn't prove to be an issue with any OS X systems, since the support is already there, just setting up to compile with it can take some doing.  

i personally have NOT been experiencing bugs 1, 2, 3 or 5 as mentioned above.  This could be because you are not running Jaguar, it could be that you are not running the most up to date SDL, SDL_image, or libvorbis.. dunno.  you might try replacing ALL of those from CVS versions and recompiling as mentioned in the howto.. give it a shot, the worst that could happen is you would be no better off!

the speed issue *IS* a bug that the team is aware of.  They are hard at work finding a solution, and one way or another, it will be solved very soon.  Solving it was a matter of #undefing a single line of code, but I shall leave the more elegant solutions to the UQM team.

Good luck.

Logged
Death 999
Global Moderator
Enlightened
*****
Offline Offline

Gender: Male
Posts: 3848


We did. You did. Yes we can. No.


View Profile
Re: A few more bugs
« Reply #4 on: February 04, 2003, 01:30:37 am »

I did all of the library loads in the HOWTO, but I could not get SDL_mixer to compile properly. I tried the game and it mostly worked anyway, so I just played, figuring that the SDL_mixer library was statically linked. If it isn't, then how does the game run?

So everything is up to date. BTW, my computer is an 800 MHz G4, so raw speed shouldn't be a problem...
Logged
Nic.
Guest


Email
Re: A few more bugs
« Reply #5 on: February 04, 2003, 02:08:52 am »

Quote
I did all of the library loads in the HOWTO, but I could not get SDL_mixer to compile properly. I tried the game and it mostly worked anyway, so I just played, figuring that the SDL_mixer library was statically linked. If it isn't, then how does the game run?

Easy, it doesn't use SDL_mixer.  Smiley  It uses MixSDL, which is a from-scratch implementation written by fOSSiL specifically for UQM (although I'm sure it will find other uses soon, it works quite well).   SDL_mixer is never referenced, and doesn't actually need to be installed (save maybe for curing some weirdness with the build scripts).

In the current CVS, SDL_mixer has been completely removed in lieu of using MixSDL.  Therefore, Mr. McNamara's next interim release is expected to have all references to installing SDL_mixer removed.  Wink
Logged
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: A few more bugs
« Reply #6 on: February 04, 2003, 02:40:55 am »

Nic is exactly right.  Smiley  

I already have the SDL_Mixer information removed from the howto, just have to reupload to Nic's site.
Logged
Death 999
Global Moderator
Enlightened
*****
Offline Offline

Gender: Male
Posts: 3848


We did. You did. Yes we can. No.


View Profile
Re: A few more bugs
« Reply #7 on: February 04, 2003, 06:17:27 am »

- Crash in melee after killing a chmmr with a pkunk (it was previously damaged). The pkunk was my last ship; the chmmr was not the computer's last ship.

- the serious slowdown only occurs after a while. Then it randomly occurs after liftoff from a planet, being on the same solar system screen as other ships, or conversation with an alien (for some reason, conversation with the commander doesn't do this). Won't go away until I quit.

- I did manage to hear the first part of a conversation, once. It was the pkunk homeworld.

- The bug about not advancing the text keeps me from talking to the orz at all (since the computer tells me something without accompanying speech beforehand, presumably?)

- an extensive search of key combinations turns up no way to escape (I tried spacebar and every key on the board, and shift and every key on the board). I think I've seen this before.
A list of keys would be nice - player 2 keys as well (if they exist... I couldn't find them in melee).
Logged
Death 999
Global Moderator
Enlightened
*****
Offline Offline

Gender: Male
Posts: 3848


We did. You did. Yes we can. No.


View Profile
Re: A few more bugs
« Reply #8 on: February 04, 2003, 06:19:16 am »

Oh yeah, and the planet disappears while the lander is taking off. Once again, no big deal, but you probably want to fix it eventually.
Logged
Nic.
Guest


Email
Re: A few more bugs
« Reply #9 on: February 04, 2003, 07:28:35 am »

Quote
Oh yeah, and the planet disappears while the lander is taking off. Once again, no big deal, but you probably want to fix it eventually.

That behaviour matches trhe 3DO.  I've sent in a patch for this and had it rejected because the current behaviour is technically "correct"

After 1.0, they may be willing to revisit the issue, but for now, the lander comes back over a blank starfield.  Cope.  Smiley
Logged
Death 999
Global Moderator
Enlightened
*****
Offline Offline

Gender: Male
Posts: 3848


We did. You did. Yes we can. No.


View Profile
Re: A few more bugs
« Reply #10 on: February 05, 2003, 08:54:58 pm »

Should I migrate these bugs to the new database? I checked, and they aren't already in there.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!