The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
April 21, 2021, 06:33:00 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Mac OS X Installing trouble
« previous next »
Pages: 1 [2] Print
Author Topic: Mac OS X Installing trouble  (Read 6786 times)
EldritchEvil
Zebranky food
*
Offline Offline

Gender: Male
Posts: 9


Only eats Khor-Ah!


View Profile WWW
Re: Mac OS X Installing trouble
« Reply #15 on: March 01, 2003, 09:19:59 pm »

Regarding browsers, OmniWeb works great.

Someday I WILL have 10.2!
Logged

www.warsmith.org

Go!  Go!  Go!
:: red5un ::
Guest


Email
Re: Mac OS X Installing trouble
« Reply #16 on: March 02, 2003, 06:38:14 pm »

got it working by d/l'ing the libraries off the link you gave me...

it's the .dmg from source forge that was messed up...
(should've read the ealier posts...my bad)

side note; by selecting your text you can spell check your message, for all you hard headed folk like me who don't want to change their web browser....d-_-b
Logged
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #17 on: March 02, 2003, 06:59:57 pm »

Hrm, downloaded the SF package to check yesterday, and it worked all right-- looks like it was just an issue with your individual download.  However, will get a buddy to d/l and make sure everything is intact for them too.

Robert.
Logged
:: red5un ::
Guest


Email
Re: Mac OS X Installing trouble
« Reply #18 on: March 02, 2003, 07:40:49 pm »

i know it wasn't an individual d/l problem because i tried several times on differetn servers...

i'm running 10.2.4 on an dual g4 agp 450 ati rage pro 128...

btw, how do activate screen scaling?
Logged
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #19 on: March 02, 2003, 09:13:15 pm »

Okay, have (thanks to Nic) gotten a copy of the 10.1 package maker, and created packages that SHOULD be compatible.  I am uploading them to his site for testing, and ask any 10.1 users to please download them and post a message here saying whether it works, okay?  

Keep in mind that this package is TOTALLY unsupported by anyone, ESPECIALLY me, and may cause smoke to issue forth from your studio display, get your wife pregnant, etc.  If it works, well, then it should become the SourceForge package, and then it will be all happy/supported/*smell good* and the only one likely to get your wife pregnant is me.  Wink

Yes, i've lost it.  Wink

they will be at http://www.submedia.net/uqm

Give me two hours or so.

Roberto.
Logged
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #20 on: March 02, 2003, 11:35:49 pm »

Okay, it's uploaded.  10.1 users, have at it.

Robert.
Logged
EldritchEvil
Zebranky food
*
Offline Offline

Gender: Male
Posts: 9


Only eats Khor-Ah!


View Profile WWW
Re: Mac OS X Installing trouble
« Reply #21 on: March 03, 2003, 01:43:42 am »

IT WORKS!  It works it works it works it works it works!

Grin Grin Grin Grin Grin Grin Grin Cheesy Cheesy Cheesy Cheesy
Logged

www.warsmith.org

Go!  Go!  Go!
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #22 on: March 03, 2003, 02:20:26 am »

Alrighty then, am uploading to replace the SourceForge package as we speak.  The unfortunate thing about the older packagemaker is it will not allow me to force install of the libraries to the first drive.

So, as a further note to OS X users, make sure to install the libraries to the first partition of your first hard drive.  The UQM app you can put wherever you like.

With this advisory, though, I think we're in better shape with this new package, which will allow non-Jaguar users to play.  Seems to be working so far!

Peace out, word to your mother, etc.

Robert.
Logged
fwiffo42
Zebranky food
*
Offline Offline

Posts: 10


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #23 on: March 03, 2003, 05:34:13 pm »

I'm having problems with the keyboard definitions on Mac OS X.  I looked in the starcon.key file and the arrow keys are definied for player 1, but they don't work.  Somehow the keys 'i', 'j', 'k', and 'l' are the directional keys.  Also, I can't get a key to work for the secondary weapon.  Any thoughts?

-fwiffo
Logged
mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #24 on: March 03, 2003, 05:49:14 pm »

Is this with the Mac OS X Package, or a compile on your own?  The reason I ask is, we had a *similar* (although not the same) problem that was holding the OS X release back, and had to do with the config.h.in, which needed to be changed for the OS X build.  For me, however, NONE of the keys would work, they weren't simply mis-mapped.

If it *is* the OS X package, be sure that you have not changed the location of the content directory, as it must be in the same directory as the app.  If you haven't done anything funky, I'm not exactly sure what it would be, or why the keys would be mapped to strange values.  You might try copying the uqm executable from the" /Ur-Quan Masters.app/Content/Macos" directory into the directory with content in it.  something like this:

open a terminal window.
cd to directory containing Ur-Quan Masters app.
su
<enter administrator password>
cp "Ur-Quan Masters/Content/MacOS/uqm" .

Now try running the executable from the command line, explicitly stating the location of the content.  Like this:

./uqm -n=content/

Does this help?  If you compiled a copy for OS X yourself, I can be of some help in setting the directories properly, but I've basically written what I can think of to try beyond that.

Robert.
Logged
fwiffo42
Zebranky food
*
Offline Offline

Posts: 10


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #25 on: March 04, 2003, 06:50:55 pm »

It turns out I was running the wrong executable, I was running a version I had compilied earlier and didn't realize the new one went to a different place.  So, now the keys work but I get no sound effects, only music.  Any idea where I should look to find this problem?  This is definitely with the sourceforge distrobution.

Thanks,

Fwiffo
Logged
seankreynolds
Zebranky food
*
Offline Offline

Gender: Male
Posts: 39


Lovin' the game


View Profile WWW
Re: Mac OS X Installing trouble
« Reply #26 on: March 19, 2003, 11:14:28 pm »

Any chance the save game files can be made not-invisible?
« Last Edit: March 20, 2003, 12:11:01 am by seankreynolds » Logged

mcnamara
Zebranky food
*
Offline Offline

Posts: 29


I love YaBB 1G - SP1!


View Profile
Re: Mac OS X Installing trouble
« Reply #27 on: March 20, 2003, 07:32:56 pm »

Hey,

This isn't just a Mac OS X thing, it's common to all the UNIX platforms. All the save games can be found in ~/.uqm/save.  Also, they aren't really invisible, you just can't see them as is from the finder.  I am told that you can use Tinkertool to set those as viewable from the finder, so you might try that.  Do a search on Versiontracker.

Robert.
« Last Edit: March 20, 2003, 08:03:39 pm by mcnamara » Logged
Pages: 1 [2] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!