The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
September 18, 2021, 04:28:46 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Issue with macOS 11 (Big Sur)
« previous next »
Pages: [1] Print
Author Topic: Issue with macOS 11 (Big Sur)  (Read 556 times)
dixius99
Zebranky food
*
Offline Offline

Posts: 4



View Profile
Issue with macOS 11 (Big Sur)
« on: November 15, 2020, 08:25:35 pm »

I recently updated macOS to the latest version (Big Sur). When I try to install the latest Ur Quan Masters, the game will launch fine, and I can hear the background music, etc., but the screen is a white blank, whether in full screen or windowed mode.

I tested in a macOS Mojave virtual machine and it works fine there.

Not sure whether the same issue occurs in Catalina, since I don't have a copy installed anywhere to test.

Logged
Michael Martin
Core Team
*Smell* controller
*****
Offline Offline

Posts: 387



View Profile
Re: Issue with macOS 11 (Big Sur)
« Reply #1 on: November 19, 2020, 09:11:41 am »

Oddly, I can't replicate this, but it doesn't surprise me that this is happening under some circumstances. Mojave broke every single SDL1-based application I tried except UQM, and it worked under Catalina as well.

I've been working on a longer-term solution for this for awhile; when I get a test release built and running on Big Sur myself I'll post about it here.

In the meantime; open up ~/.uqm/uqm.cfg in TextEdit or any other text editor and there should be a line in it that looks something like "alwaysgl=BOOLEAN:false". Change the "false" to "true" on that line and see if you have any better luck.
Logged
dixius99
Zebranky food
*
Offline Offline

Posts: 4



View Profile
Re: Issue with macOS 11 (Big Sur)
« Reply #2 on: November 19, 2020, 09:54:14 pm »

May be interesting to know that while I have a ~/.uqm folder, there's no uqm.cfg file within it. Just 2 empty folders named save and teams. Not sure if that is expected for a new install.

Creating uqm.cfg manually with the line you shared does fix my problem though!
Logged
Michael Martin
Core Team
*Smell* controller
*****
Offline Offline

Posts: 387



View Profile
Re: Issue with macOS 11 (Big Sur)
« Reply #3 on: December 07, 2020, 02:58:44 am »

And now that I've gotten a build that worked on my Big Sur machine:

https://forum.uqm.stack.nl/index.php?topic=7874.0

The longer-term solution for this is an entirely new graphics backend that includes Metal support, which should future-proof things for a good while. Links to the UQM 0.8 release candidate have been posted in that thread.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!