The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
May 26, 2024, 11:37:26 pm
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  General UQM Discussion (Moderator: Death 999)
| | |-+  Adding flatpak support, officially or unofficially
« previous next »
Pages: [1] Print
Author Topic: Adding flatpak support, officially or unofficially  (Read 421 times)
Halleck
Enlightened
*****
Offline Offline

Gender: Male
Posts: 752


Personal Text


View Profile WWW
Adding flatpak support, officially or unofficially
« on: October 24, 2023, 11:56:45 am »

Hey folks, long time no see!

I have recently discovered a flatpak template for UQM 0.8.0. I was looking for a way to run UQM on my steam deck and it works perfectly.

I started an issue on this repo to discuss with its author the possibility of publishing UQM to Flathub to facilitate much greater ease of use.

The author has expressed interest in getting this build target incorporated officially into the UQM project. I wanted to see if that's feasible. I'm willing to do some initial work to get this going but I can't commit to being a long-term maintainer. But given UQM's very infrequent release cycle I don't think it would be terribly difficult to keep supporting it once it's integrated.

If the team isn't interested in officially supporting flatpak, I think I still want to try publishing it myself to flathub unofficially. It will just make it a lot easier to support on platforms like the Steam Deck that can't easily consume other build formats.

Happy to discuss more here or over IRC (I popped by recently but nobody was online) or Discord. Smiley

Thanks!
Logged


Currently working on: Going outside more
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!