The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
August 16, 2022, 12:03:43 am
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  trouble building on OS X
« previous next »
Pages: 1 [2] Print
Author Topic: trouble building on OS X  (Read 4204 times)
mhildum
Zebranky food
*
Offline Offline

Posts: 3


I love YaBB 1G - SP1!


View Profile
Re: trouble building on OS X
« Reply #15 on: May 18, 2003, 12:15:58 am »

I was able to get it build in OSX.. and the wave loader works properly as well.

I downloaded and build the CVS build of SDL, and was able to build it properly (it also added sdl_config to the /usr/local/bin folder)
I couldnt properly build SDL_image.. but I just download the OSX version.

Built and installed the libogg and libvorbis libraries-

When trying to build it wouldnt find the SDL layer.. after added /usr/local/bin to the path it was able to find it.. reach the build menu.. then not actually build.

Looking at the build progress it was indicating it couldnt find the SDL_image.sh in the /src/sc2code/libs/graphics/sdl folder.

I copied the file there and the build was able to complete successfully.

Logged
Death 999
Global Moderator
Enlightened
*****
Offline Offline

Gender: Male
Posts: 3866


We did. You did. Yes we can. No.


View Profile
Re: trouble building on OS X
« Reply #16 on: May 19, 2003, 02:16:48 am »

/src?
Do you mean ($UQMHOME)/src?

In any case, thanks! Contact Nic to have him host the build, if you don't mind.
« Last Edit: May 19, 2003, 02:17:24 am by Death_999 » Logged
Pages: 1 [2] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!