The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
August 09, 2022, 10:43:58 pm
Home Help Search Login Register
News: Paul & Fred have reached a settlement with Stardock!

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Unusual input behavior?
« previous next »
Pages: [1] Print
Author Topic: Unusual input behavior?  (Read 1599 times)
TigTigger
Zebranky food
*
Offline Offline

Posts: 41



View Profile
Unusual input behavior?
« on: November 13, 2003, 09:42:42 am »

Hey,

I have an unusual problem with my keyboard and the game controls.  it seems likely it's just be wonky hardware, but, I'd like to post it and see if anyone can suggest something that I could do to determine if this is the case.

Anyway, I have an unusual problem when multiple keys are pressed.  For example, if I am pressing a key to thrust or fire, and simultaenously press and release a key to steer, it seems to register as "two" movements (i.e. the ship or lander will turn two nicks in that direction).  If the first key is released, then steering is normal.  This is very noticeable in either the melee or while controlling the planet lander, as it makes it very difficult to point the ship in the desired direction.  You think steering the lander around after the speed upgrade is hard?  Try it when you can only point the ship in 8 directions.  :-/

This occurs if any other key on the keyboard is pressed.

This is with 0.3, Windows XP.

This is with a wireless keyboard of mine.  On a hunch, I swapped it out for a regular keyboard, and the problem went away.

I wanted to compare this vs. another application to see if it's just some oddity with the keyboard, but I don't think I have a program that would respond in a similar way as uqm does to the keyboard.  If I try to scroll in one direction in a document, for example, and then press and release another arrow, it scrolls one "tick" in the new direction, not two, but then stops scrolling in the original direction.

Any comments/suggestions?

Thanks!
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Unusual input behavior?
« Reply #1 on: November 13, 2003, 01:55:59 pm »

It's almost certainly a hardware problem. A very common at that. Most keyboards don't allow every combination of keys to be pressed at once. The result being key presses not reported, or ghost keypresses.
The original sc2 came with with a key jamming program so you could experiment with your keys and adjust your config accordingly. UQM doesn't have this yet.
But the solution (or work-around rather) would still be to experiment with the keys and use other ones.
Either that or use another keyboard. Nowadays, most keyboards have this problem, so you have a better chance with old ones. Or you could use a game controller.

Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
TigTigger
Zebranky food
*
Offline Offline

Posts: 41



View Profile
Re: Unusual input behavior?
« Reply #2 on: November 13, 2003, 11:16:26 pm »

Good day,

Thanks for your reply, but, this isn't the infamous key-jamming issue, it's (appently) something different.

This is not related to any combination of keys.  Like I said, if I press any other key-- ANY other key- down on the keyboard, steering both left and right is done in two-tick imcremenets.  In Melee, with two human opponents, they are both affected, regardless of the controls I configure for them.  Your suggestion to use different key combinations will clearly not help here.

I realize that it's easy to just say "It's the hardware's fault", and certainly, that's still the most likely cause of this problem.  I am just asking for ideas on how I could verify that the keyboard is sending two keypresses in this case when I have only pressed it once, OR, if the keyboard is just behaving in a way unexpected by the program which could be fixed or worked around (depending on where the error lies).
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: Unusual input behavior?
« Reply #3 on: November 14, 2003, 01:54:21 pm »

Hmm... well, something similar to this has happened to me when I'm running gdb on the program. So it could be a timing issue. How fast is you computer btw?

I suggest you report this in the bug database and it will be investigated closer in due time.
I don't have an immediate solution.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
TigTigger
Zebranky food
*
Offline Offline

Posts: 41



View Profile
Re: Unusual input behavior?
« Reply #4 on: November 17, 2003, 10:04:46 am »

Heya,

Thanks for the update.

The machine is a AMD XP 2100+.   I have some other slower machines that I could try it on with other OSes, so I'll do that before posting a bug, if you think it will help.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!