The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
November 29, 2022, 10:37:08 pm
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  Graphics Issues
« previous next »
Pages: [1] Print
Author Topic: Graphics Issues  (Read 1960 times)
TedStudley
Zebranky food
*
Offline Offline

Posts: 3



View Profile
Graphics Issues
« on: March 27, 2007, 08:45:21 pm »

I really love UQM, (used to play it on Linux), and I want to play it on Windows. I Installed it, and now when I run it, it starts okay, but all I see is a blank screen. I can use the up and down arrows to move around on the main menu (I can still hear the noises), but there's no graphics. Can anyone help?

I'm using an e-machine with an AMD Athalon XP processor and an NVIDIA GeForce 4 graphics card.

Please help!
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Graphics Issues
« Reply #1 on: March 27, 2007, 08:52:50 pm »

I really love UQM, (used to play it on Linux), and I want to play it on Windows. I Installed it, and now when I run it, it starts okay, but all I see is a blank screen. I can use the up and down arrows to move around on the main menu (I can still hear the noises), but there's no graphics. Can anyone help?

I'm using an e-machine with an AMD Athalon XP processor and an NVIDIA GeForce 4 graphics card.
Works fine for me on a very similar machine (GeForce Ti4200, Athlon XP, Windows XP). Check your display drivers; the ones supplied with XP are useless; use NVIDIA's own drivers instead.

If that doesn't help, try using the command line to disable/enable OpenGL support and change resolution.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
TedStudley
Zebranky food
*
Offline Offline

Posts: 3



View Profile
Re: Graphics Issues
« Reply #2 on: March 27, 2007, 09:25:44 pm »

No luck. I tried everything you said, but still nothing.
Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Graphics Issues
« Reply #3 on: March 28, 2007, 08:10:55 am »

I guess that means we have to do some real troubleshooting, then. Sad

  • By "blank screen", what do you mean, exactly? Is the monitor getting a valid signal, and if so, at what resolution? What are the results of running in windowed mode?
  • Which version of UQM are you running, and with what optional packages?
  • What are the contents of the stderr.txt file generated by UQM (in its directory, I think)?
  • What are the contents of the UQM configuration files? Does deleting/renaming them help?
  • What privileges does the user account you used to install and run UQM have?
  • What is the exact version of Windows you are running (Home/Pro, 32-bit/64-bit, service pack number, language)?
  • What is the exact installed display driver (NVIDIA ForceWare version)?
  • What is the screen resolution and colour depth you are using for your Windows desktop?
  • What is the currently installed version of DirectX?
  • Are you experiencing any problems with other DirectX or OpenGL applications? If so, which?
  • Have you tried reinstalling UQM?
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
TedStudley
Zebranky food
*
Offline Offline

Posts: 3



View Profile
Re: Graphics Issues
« Reply #4 on: March 28, 2007, 06:01:43 pm »

I think I may have found the problem.

I was looking at the stderr.txt file, and I found these errors:

Quote
_GetSoundBankData(): loading lbm/menusnd01.wav
SoundDecoder_DecodeAll(): WARNING, called with a small buffer (4096)
_GetSoundBankData(): decoded_bytes 1971
_GetSoundBankData(): loading lbm/menusnd02.wav
SoundDecoder_DecodeAll(): WARNING, called with a small buffer (4096)
_GetSoundBankData(): decoded_bytes 1955
_GetSoundBankData(): loading lbm/menusnd03.wav
SoundDecoder_DecodeAll(): WARNING, called with a small buffer (4096)
_GetSoundBankData(): decoded_bytes 1576
_GetSoundBankData(): loading lbm/menusnd04.wav
SoundDecoder_DecodeAll(): WARNING, called with a small buffer (4096)
_GetSoundBankData(): decoded_bytes 2399
   'lbm/stars.ani' -- 60 bytes
   'lbm/astbig.ani' -- 492 bytes
   'lbm/astmed.ani' -- 452 bytes
   'lbm/astsml.ani' -- 452 bytes
   'lbm/blabig.ani' -- 168 bytes
   'lbm/blamed.ani' -- 168 bytes
   'lbm/blasml.ani' -- 168 bytes
   'lbm/boobig.ani' -- 191 bytes
   'lbm/boomed.ani' -- 193 bytes
   'lbm/boosml.ani' -- 194 bytes
Warning: Can't open 'lbm/mainmenu.ogg'
   'lbm/newgame.ani' -- 177 bytes
Warning: Can't open 'lbm/mainmenu.ogg'
   'lbm/newgame.ani' -- 177 bytes
   'lbm/title.ani' -- 20 bytes
   'credits/credits.ogg' -- 1741558 bytes

I don't know what the problem is past that.

I have tried reinstalling UQM several times, with no success.

Logged
Novus
Enlightened
*****
Offline Offline

Gender: Male
Posts: 1938


Fot or not?


View Profile
Re: Graphics Issues
« Reply #5 on: March 28, 2007, 06:03:51 pm »

That log extract looks entirely normal. In any case, all the warnings are related to sound, and occur when UQM is functioning normally.
Logged

RTFM = Read the fine manual.
RTTFAQ = Read the Ur-Quan Masters Technical FAQ.
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!