The Ur-Quan Masters Home Page Welcome, Guest. Please login or register.
Did you miss your activation email?
November 28, 2022, 01:26:56 pm
Home Help Search Login Register
News: Celebrating 30 years of Star Control 2 - The Ur-Quan Masters

+  The Ur-Quan Masters Discussion Forum
|-+  The Ur-Quan Masters Re-Release
| |-+  Technical Issues (Moderator: Death 999)
| | |-+  SDL initialization error on my machine
« previous next »
Pages: [1] Print
Author Topic: SDL initialization error on my machine  (Read 1514 times)
twilight
Zebranky food
*
Offline Offline

Posts: 3



View Profile
SDL initialization error on my machine
« on: June 21, 2005, 09:56:31 pm »

Sup guys. I've been trying to install the newest version from source code on my Ubuntu system, and I've come to the conclusion that I suck at installing from source, haha. I don't have much problems running the older version of the game that I installed from a .deb off of the Debian repositories, but I'd really like to play the newest version, I hope somebody can give me a little advice.
The error I get when I try to run the newer version is
Code:
Initializing base SDL functionality.
Using SDL version 1.2.8 (compiled with 1.2.8)
Could not initialize SDL: No available video device.


When I run the old version it says
Code:

Initializing SDL (pure).
SDL driver used: x11
SDL initialized.


So I guess I'm kinda curious how I get the new version of the game to tell SDL that my video device is x11, or if I missed out on getting some particular dependency?

I was also having problems with the older version and trying to get it to use ESD for sound, but I don't know if that's going to be the case in the new version cause I haven't gotten that far in running it yet, but any hints on that would be appreciated too, I tried using an argument of --sound=ESD but it didn't work. Is there something else about the syntax of sound arguments that I'm missing, or perhaps something else I'm supposed to specify?
Logged
meep-eep
Forum Admin
Enlightened
*****
Offline Offline

Posts: 2847



View Profile
Re: SDL initialization error on my machine
« Reply #1 on: June 21, 2005, 10:14:07 pm »

These are SDL issues. You need to have a version of SDL which is compiled with x11 support to run in X. There's probably a package for that.
Similarly for the various sound drivers that SDL supports.
You can override the default video and audio driver with respectively the environment variable SDL_VIDEODRIVER and SDL_AUDIODRIVER. See here for the possible values.
Logged

“When Juffo-Wup is complete
when at last there is no Void, no Non
when the Creators return
then we can finally rest.”
twilight
Zebranky food
*
Offline Offline

Posts: 3



View Profile
Re: SDL initialization error on my machine
« Reply #2 on: June 22, 2005, 12:37:12 am »

Cool, that's exactly the stuff I needed to know, thank you very much. I got the sound working now on the old version thanks to that info, and I'm pretty sure I'll be able to get the new one working now too, once I mess with it a little more. You were right, there was a SDL package compiled for x11, even one compiled specifically for ESD. I hadn't added non-main repositories to my apt-get yet cause I just formatted, and so didn't see the packages. Oh well..

Anyway, thanks again for the help, see you later.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!